r33 gtst running problem - Skyline Owners Forum

Welcome to the SkylineOwners.Com website. We aim to provide you with the largest knowledgebase anywhere on the internet for the Nissan Skyline.


Go Back   Skyline Owners Forum > Skyline Torque > General


General Skyline related chat only please
Sponsored By: www.OnlineCarParts.co.uk

Like Tree1Likes
  • 1 Post By swifty1
Reply
 
LinkBack Thread Tools Rate Thread
Old 29-10-2017, 06:09 PM   #1
Registered User
 
Join Date: Oct 2017
Posts: 14
Club ID#: 85489


Trade Feedback: (0)


View My Pictures
Unhappy r33 gtst running problem

hi guys i have a spec 1 gtst which runs perfecly fine and boost as it should in 1st but when boosting in the rest of the gears around 4.5k its almost as though the engine shuts down for a split second obviously causing boost to drop. if i ease the throttle on it does go past it without dropping or cutting out. have replaced coils plugs gapped at 0.8 replaced airmass fuel filter checked all hoses. really am stuck for where to go next and what and how to check. any help would be massively appreciated thanks in advance dan

mods... car has hks straight through exhaust. front mount intercooler. shroom airfilter. running standard ecu
swifty1 is offline   Reply With Quote Share on facebook
Sponsored Links
Advertisement
 
Old 29-10-2017, 08:51 PM   #2
Seasoned Member
 
sparkso's Avatar
 
Drives: 1996 R33 gtst
Join Date: Jan 2008
Location: northern ireland
Posts: 2,055
Club ID#: 13879


Trade Feedback: (17)


View My Pictures
Remap probably needed to sort out the overfuelling your experiencing
sparkso is offline   Reply With Quote
Old 29-10-2017, 09:53 PM   #3
Registered User
 
Join Date: Oct 2017
Posts: 14
Club ID#: 85489


Trade Feedback: (0)


View My Pictures
Quote:
Originally Posted by sparkso View Post
Remap probably needed to sort out the overfuelling your experiencing
thanks for reply. i have a stage 1 ecu on order from bell auto service hope that sorts it
swifty1 is offline   Reply With Quote
Old 01-11-2017, 04:12 PM   #4
Registered User
 
Join Date: Oct 2017
Posts: 14
Club ID#: 85489


Trade Feedback: (0)


View My Pictures
fixed

Quote:
Originally Posted by swifty1 View Post
thanks for reply. i have a stage 1 ecu on order from bell auto service hope that sorts it
all fixed thanks to bells autos with a stage 1 ecu
sparkso likes this.
swifty1 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +1. The time now is 02:45 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2002 - 2019, Verticalscope Inc.