R34 GT-T 1998 RB25DET NEO - Skyline Owners Forum

Welcome to the SkylineOwners.Com website. We aim to provide you with the largest knowledgebase anywhere on the internet for the Nissan Skyline.


Go Back   Skyline Owners Forum > Skyline Torque > General


General Skyline related chat only please
Sponsored By: www.OnlineCarParts.co.uk

Like Tree1Likes
  • 1 Post By pengellypurple
Reply
 
LinkBack Thread Tools Rate Thread
Old 24-03-2018, 01:00 AM   #1
Registered User
 
Drives: 1998 Nissan Skyline R34
Join Date: Nov 2017
Location: Vancouver
Posts: 9
Club ID#: 86097

Country Flag

Trade Feedback: (0)


View My Pictures
R34 GT-T 1998 RB25DET NEO

Help please I recently just got my car insured and it decided to not wanna work now so basically I’ve had a straight pipe for about 2-3 months the car worked perfectly fine no problems at all it has a blow off valve on it aswell it’s been on it since 1-2 years no problems aswell so basically 1-2 weeks ago when I got my car insured I went to a meet and when I was leaving the meet I decided to rev it and when I did it redlined but had a sputtering sound like a rev limiter even though I don’t have one and it sounded like something was stuck in the car. Later on it was driveable and a week or so later the issue became even worst to the point where the sputtering was happening at about 4-5k rpm however I could go through and redline it but it sounded like it was dying or something then I just let it wait a bit and now it’s worst when I start it it’s perfectly fine but still sputters around 4-5 but if I drive it for about 5 minutes the car will not go over 2k it just starts sputtering and feels like it’s dying and sometimes it even decides to turn off by it self then when you try starting it it doesn’t want to but after 10-20 mins it will start up like nothings wrong please help I don’t know much about cars so sorry but that’s the best I could explain it
MValasra is offline   Reply With Quote Share on facebook
Sponsored Links
Advertisement
 
Old 24-03-2018, 01:04 AM   #2
Registered User
 
Drives: 1998 Nissan Skyline R34
Join Date: Nov 2017
Location: Vancouver
Posts: 9
Club ID#: 86097

Country Flag

Trade Feedback: (0)


View My Pictures
Here are some videos to explain it https://youtu.be/UVNc-CSiXEQ https://youtu.be/ljVSyQVWoH8
MValasra is offline   Reply With Quote
Old 24-03-2018, 01:13 AM   #3
Registered User
 
Drives: 1998 Nissan Skyline R34
Join Date: Nov 2017
Location: Vancouver
Posts: 9
Club ID#: 86097

Country Flag

Trade Feedback: (0)


View My Pictures
also forgot to mention prior to this issue I’ve replaced spark plugs ngk and coils and another thing is that when it’s on idle and I turn on the lights and use the power windows it starts to feel like it’s dying even more and sometimes usually turns off then doesn’t want to start after 10-20 mins
MValasra is offline   Reply With Quote
Old 26-05-2018, 09:18 AM   #4
Seasoned Member
 
pengellypurple's Avatar
 
Drives: r34 gtt
Join Date: Feb 2011
Location: leicester
Posts: 291
Club ID#: 27961


Trade Feedback: (1)


View My Pictures
Always start with the simple cheap things,you've changed the plugs and packs,good,check the earths for the engine,if need be make some simple heavy cables up and find any earthing points in the engine bay and attach to the block,next would be fuel,the wiring for the fuel pump can be a suspect,if need be search on here for the hard wiring setup for the pump,always worth it to future proof for upgrades,is the car standard? Possible boost controller problem
V-SpecII likes this.
pengellypurple is offline   Reply With Quote
Old 26-05-2018, 02:45 PM   #5
Seasoned Member
 
Drives: R34 Skyline
Join Date: Mar 2015
Location: Nuneaton
Posts: 347
Club ID#: 58090

Country Flag

Trade Feedback: (0)


View My Pictures
Top advice ^^^
V-SpecII is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +1. The time now is 02:34 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2002 - 2019, Verticalscope Inc.