GTT high idle RB25DET NEO - Skyline Owners Forum

Welcome to the SkylineOwners.Com website. We aim to provide you with the largest knowledgebase anywhere on the internet for the Nissan Skyline.


Go Back   Skyline Owners Forum > Skyline Torque > General


General Skyline related chat only please
Sponsored By: www.OnlineCarParts.co.uk

Reply
 
LinkBack Thread Tools Rate Thread
Old 12-10-2018, 10:15 AM   #1
Registered User
 
ceoont's Avatar
 
Join Date: Apr 2017
Posts: 31
Club ID#: 82809


Trade Feedback: (0)


View My Pictures
GTT high idle RB25DET NEO

Recently my RB25 has not been idling correctly, it started a few weeks ago, idled at 2k stable, so I removed idle air control valve and cleaned it, idled perfect again for a few days. Now the idle sits at 3k, and never drops. Any ideas would be brilliant as the car is fairly un-driveable at the moment, it has a full straight through from turbo back so it's way to loud idling at 3k. Any help would be greatly appreciated, thanks in advance. Car has also had coilpacks changed last week which made no difference

Sent from my SM-G955F using Tapatalk
ceoont is offline   Reply With Quote Share on facebook
Sponsored Links
Advertisement
 
Old 07-11-2018, 04:50 PM   #2
Seasoned Member
 
Join Date: Jun 2017
Posts: 61
Club ID#: 83841


Trade Feedback: (0)


View My Pictures
If you do anything with the idle you will have to reset the tps.

They both work in sync.

I would also check for vacuum leaks, and do a boost leak test as this is good at finding air leaks.
Dazsw is offline   Reply With Quote
Old 07-11-2018, 07:28 PM   #3
Registered User
 
ceoont's Avatar
 
Join Date: Apr 2017
Posts: 31
Club ID#: 82809


Trade Feedback: (0)


View My Pictures
Quote:
Originally Posted by Dazsw View Post
If you do anything with the idle you will have to reset the tps.

They both work in sync.

I would also check for vacuum leaks, and do a boost leak test as this is good at finding air leaks.
Any idea how to reset the TPS please mate? TPS and air flow meter work in sync? Thanks the for the reply

Sent from my SM-G955F using Tapatalk
ceoont is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +1. The time now is 10:29 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2002 - 2019, Verticalscope Inc.