GTS Air/Fuel Issue? - Skyline Owners Forum

Welcome to the SkylineOwners.Com website. We aim to provide you with the largest knowledgebase anywhere on the internet for the Nissan Skyline.


Go Back   Skyline Owners Forum > Skyline Torque > N/A Forum


N/A Forum Naturally aspirated technical forum

Reply
 
LinkBack Thread Tools Rate Thread
Old 13-01-2011, 09:38 PM   #1
You Cant Touch This
 
theinfamous's Avatar
 
Drives: R33 GTST Spec 2
Join Date: Aug 2008
Location: Poole
Posts: 143
Club ID#: 16655

Country Flag

Trade Feedback: (4)


View My Pictures
GTS Air/Fuel Issue?

Hi guys, I picked up a cheap GTS (RB25) last month. Car is over all in good condition. I notice the revs drop and the car can stall when the clutch is down (gets worse when warm) and I was going to give the IAC valve a clean asap. Today however the car has started to Kangaroo as if its not getting any air/fuel? Had to drive it to work not going over 1800k revs.....

Could this be the air flow meter, or the fuel pump, or maybe the plugs?? I had to change a fuel pump on my last GTST but that just went and never started again. Coil pack also went on the GTST so replaced them, but that was at high revs....
Car is very standard bar the panel K&N.
Any suggestions will be appreciated


theinfamous is offline   Reply With Quote Share on facebook
Sponsored Links
Advertisement
 
Old 14-01-2011, 09:11 PM   #2
Seasoned Member
 
shawny's Avatar
 
Drives: R33 Project 300s / vauxhall zafira / orange transit
Join Date: Sep 2005
Location: Kent
Posts: 511
Club ID#: 5483

Country Flag

Trade Feedback: (6)


View My Pictures
my air flow meter went and it done a similar thing you can test it by checking the voltage at the signal wire but cant rember which one it is sorry . nice looking gts
__________________
Project 300S built not bought
shawny is offline   Reply With Quote
Old 17-01-2011, 09:26 PM   #3
You Cant Touch This
 
theinfamous's Avatar
 
Drives: R33 GTST Spec 2
Join Date: Aug 2008
Location: Poole
Posts: 143
Club ID#: 16655

Country Flag

Trade Feedback: (4)


View My Pictures
Thanks for that

I kind of think its a fuel issue (pipe, pump?) now as you can floor it and it pulls hard then when you ease around 2k it sounds and feels like there is a block and nothing happens even with the pedal to the floor??
theinfamous is offline   Reply With Quote
 
Old 19-01-2011, 11:20 AM   #4
New Zealand Area Rep
 
b00stinz's Avatar
 
Drives: 1991 R32 RB20DET
Join Date: Mar 2008
Location: New Zealand
Posts: 797
Club ID#: 14853

Country Flag

Trade Feedback: (0)


View My Pictures
Try changing your fuel filter, a guy on SDU had this similar issue, tore out his hair trying to find out what it was, replaced heaps of stuff then finally realised it was the fuel filter!

Start at basics first, test your fuel pump voltage, test your AFM, test your coils.

When I did a +T, the coils which went so well when my car was non turbo, suddenly failed, they car would stutter and struggle to rev past 5k. So its a possibility there too. If it is your coils, I can tell you an easy cheap way to fix them like I did, car was boosting to redline in no time!
__________________
Slippery when dry
b00stinz is offline   Reply With Quote
Old 19-01-2011, 10:25 PM   #5
You Cant Touch This
 
theinfamous's Avatar
 
Drives: R33 GTST Spec 2
Join Date: Aug 2008
Location: Poole
Posts: 143
Club ID#: 16655

Country Flag

Trade Feedback: (4)


View My Pictures
Thanks for that info
Funny enough I changed the fuel filter lastnight.....havnt given the car a good run to see if its helped yet. But fingers crossed the 7 filter might have done it!! lol

Was going to change the plugs soon and check the coil packs, they were going on my last GTST and would miss fire at the higher end of the revs.
theinfamous is offline   Reply With Quote
Old 20-01-2011, 07:08 AM   #6
New Zealand Area Rep
 
b00stinz's Avatar
 
Drives: 1991 R32 RB20DET
Join Date: Mar 2008
Location: New Zealand
Posts: 797
Club ID#: 14853

Country Flag

Trade Feedback: (0)


View My Pictures
Sweet as, hope it works out, I hate it when my car doesnt run sweet. Literally keeps me up at night.
__________________
Slippery when dry
b00stinz is offline   Reply With Quote
Old 22-01-2011, 10:33 PM   #7
You Cant Touch This
 
theinfamous's Avatar
 
Drives: R33 GTST Spec 2
Join Date: Aug 2008
Location: Poole
Posts: 143
Club ID#: 16655

Country Flag

Trade Feedback: (4)


View My Pictures
Car seems all good now with the fuel issue....(7 fuel filter, get in!!!)

I even gave the AAC a good clean today and it now drops to 800k when I press the clutch and idles at 700k
Well worth doing.........
theinfamous is offline   Reply With Quote
Old 23-01-2011, 09:58 AM   #8
New Zealand Area Rep
 
b00stinz's Avatar
 
Drives: 1991 R32 RB20DET
Join Date: Mar 2008
Location: New Zealand
Posts: 797
Club ID#: 14853

Country Flag

Trade Feedback: (0)


View My Pictures
Quote:
Originally Posted by theinfamous View Post
Car seems all good now with the fuel issue....(7 fuel filter, get in!!!)

I even gave the AAC a good clean today and it now drops to 800k when I press the clutch and idles at 700k
Well worth doing.........
Hahahaha! YUSS
__________________
Slippery when dry
b00stinz is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +1. The time now is 08:11 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2002 - 2019, Verticalscope Inc.