RB20E - WHAT FILTER DO YOU HAVE ?? - Skyline Owners Forum

Welcome to the SkylineOwners.Com website. We aim to provide you with the largest knowledgebase anywhere on the internet for the Nissan Skyline.


Go Back   Skyline Owners Forum > Skyline Torque > N/A Forum


N/A Forum Naturally aspirated technical forum

Reply
 
LinkBack Thread Tools Rate Thread
Old 19-08-2013, 08:36 AM   #1
NEW TO ALL THINGS NISSAN
 
Skyline-Noob's Avatar
 
Drives: Nissan Skyline GTS 2L Auto Spec 1
Join Date: Dec 2012
Location: SOUTHEND-ON-SEA
Posts: 1,103
Club ID#: 41889

Country Flag

Trade Feedback: (0)


View My Pictures
Question RB20E - WHAT FILTER DO YOU HAVE ??



Up until recentley I was going to get a K&N Pod..But a couple of friends both with EVO 7 and 8 told me to go for an Apexi one..

Since then I have been told that the Apexi one : caused turbulence in the afm, causing it to overfuel badly..??

now I dont know if my car will respond in the same way that "STUARTTHEFISH's" did and overfuel..

But I really hope that I dont have to swap my new filter over..



I'd just like to ask any other RB20E drivers what filters y'all have installed in your R33's ???


Please reply asap

Regards



Martin.
Skyline-Noob is offline   Reply With Quote Share on facebook
Sponsored Links
Advertisement
 
Old 19-08-2013, 09:27 AM   #2
Moderator

Moderator

 
StuartTheFish's Avatar
 
Drives: Spec 1 GTS25t
Join Date: Jul 2010
Location: Harrogate
Posts: 12,294
Club ID#: 25144

Country Flag

Trade Feedback: (1)


View My Pictures
It may be okay if you locate it further away from the afm, but when bolted directly onto the afm it caused the afm signal to go too high. Don't forget that I've got a gtst though, on your na it might not matter since the airflow won't get anywhere near as high to start with. Mine only had problems while boosting.
StuartTheFish is offline   Reply With Quote
Old 19-08-2013, 09:27 AM   #3
AKA Frenchie

Administrator

 
SPEEDR33PER's Avatar
 
Drives: R33 GTS-T,FULLY MODIFIED ESCORT VAN and the SNOOPYMOBIlE 2
Join Date: May 2006
Location: tillicoultry scotland
Posts: 25,941
Club ID#: 7722

Country Flag

Trade Feedback: (13)


View My Pictures
i had an apexi one in mine and never caused any problems and that ran from standard power right up to 400bhp and mine was an rb25det
__________________
WWW.JAPSPEED.CO.UK

skylineowners.com mechanic and mot tester
SCOTLAND,CLACKMANNAN
SAUDI ARABIA


Quote:
Originally Posted by andyneed4speed View Post

Nice to see the scottish contingent but I didn't realise we had the legendary Speedr33per in our midst
SPEEDR33PER is offline   Reply With Quote
 
Old 19-08-2013, 09:30 AM   #4
Moderator

Moderator

 
StuartTheFish's Avatar
 
Drives: Spec 1 GTS25t
Join Date: Jul 2010
Location: Harrogate
Posts: 12,294
Club ID#: 25144

Country Flag

Trade Feedback: (1)


View My Pictures
Mine maxed out the afm signal as soon as I was making boost, hitting 5.12v straight away, which caused the injector duty to skyrocket and my afr's go too rich for my aem wideband to register.

I'd tried repairing the afm, replacing the afm, replacing the wires from the afm to the ecu, tried two different ecu's, triple checked for any leaks, replaced my entire intake twice, etc. I'd been trying to fix it for half a year or so, there are even threads on here that I started while trying to figure out what the hell was going on.

As soon as I got rid of that filter, it cured it, my afm signal never goes above 4.8v, and my afr's now sit happily in the mid 11's at full throttle.

I think it was the cone inside the filter that was the problem, as that ends up right next to the hotwire of the afm. Moving the filter further away on a bit of pipe may have helped, but I saw a brand new k&n for about 30 quid delivered so got that instead to save hassle. Been perfect ever since.

Last edited by StuartTheFish; 19-08-2013 at 09:39 AM.
StuartTheFish is offline   Reply With Quote
Old 19-08-2013, 09:53 AM   #5
Seasoned Member
 
E5_ARW's Avatar
 
Drives: R33 GTST, Mazda 3 & Volvo V40
Join Date: May 2007
Location: Wolverhampton
Posts: 4,504
Club ID#: 11494

Country Flag

Trade Feedback: (0)


View My Pictures
Got a Blitz on my gtst as it came with the car and i dont want to pay out any more cash when i dont need to but i would always go for the apexi.

Heres a link to show why http://www.mikekemper.com/elantra/filters/
__________________
Quote:
Originally Posted by Yella View Post
You have a Skyline treat it with respect, you wouldn't give a supermodel g/f a elizebeth duke sovereign ring to wear would you !!!
E5_ARW is offline   Reply With Quote
Old 19-08-2013, 09:56 AM   #6
Moderator

Moderator

 
StuartTheFish's Avatar
 
Drives: Spec 1 GTS25t
Join Date: Jul 2010
Location: Harrogate
Posts: 12,294
Club ID#: 25144

Country Flag

Trade Feedback: (1)


View My Pictures
Here's one of my old threads if you fancy a read:

https://www.skylineowners.com/forum/s...d.php?t=164005

Basically I found my boost spikes were down to the actuator feed being in the pipe after the intercooler, and the afm maxing out was the air filter.
StuartTheFish is offline   Reply With Quote
Reply

Bookmarks

Tags
air filter, apexi, decisions, k&n, pod filter


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +1. The time now is 08:21 PM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2002 - 2019, Verticalscope Inc.