RB25DE TPS issue - Skyline Owners Forum

Welcome to the SkylineOwners.Com website. We aim to provide you with the largest knowledgebase anywhere on the internet for the Nissan Skyline.


Go Back   Skyline Owners Forum > Skyline Torque > N/A Forum


N/A Forum Naturally aspirated technical forum

Reply
 
LinkBack Thread Tools Rate Thread
Old 18-09-2019, 11:48 PM   #1
Registered User
 
R33jord's Avatar
 
Join Date: Sep 2019
Posts: 2
Club ID#: 90514


Trade Feedback: (0)


View My Pictures
RB25DE TPS issue

Hi all, I've recently purchased as R33 GTS, now, the car will start and idle fine and sometime rev right up the limiter. However when driving under load it feels very weak on power and wont rev, seems to misfire. We believe the issue to be revolving around the TPS setup, any thoughts. We will be having a look with at the voltage ect over the weekend, can anyone tell me the voltage tolerances on these please.

Cheers
Jordan
Attached Thumbnails
Click image for larger version

Name:	FB_IMG_1568843298525_1568843313803.jpg
Views:	11
Size:	100.6 KB
ID:	110520  
R33jord is offline   Reply With Quote Share on facebook
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT +1. The time now is 01:50 PM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2002 - 2019, Verticalscope Inc.