Skyline Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 350GT cranks strong but fails to start at the moment. I have replaced a number of parts recently: Knock Sensor, Spark Plugs, Ignition Coils, Crankshaft Position Senor, Camshaft Position Sensors x 2 and the Fuel Injectors too!

I'm thinking that my issue may be related to the Fuel Pump. I have checked the relay and fuses and they seem to be ok. What I find is that when the ignition is switched to the on position, you can hear the fuel pump prime once per session. That is to say when you attempt to start the car it works once only. To hear the fuel pump prime again, you would have to switch off the engine and remove the key and reinsert if that makes sense?

Is that expected behaviour, or should it prime each attempt at starting the car?
 

·
Super Moderator
Joined
·
8,969 Posts
No it will just attain the required pressure and not run until it drops below the set threshold, as there isn't a return line, have you tried checking the fuel pressure with a gauge?

Have the error codes been checked?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I have a fuel pressure gauge but am not sure how to use it. I don't think I have the right connectors to hook it up.

I don't have a code reader. I've made a video recording of whatever the onboard code reader has detected but I struggle to read it myself... The long/short flashes confuse me!
 

·
Super Moderator
Joined
·
8,969 Posts
I am hosting the manual for the 350GT/G35 in this section, it will show you how to hook up a gauge and test, TBH you really need to use a code reader to diagnose faults, and one that is JOBD and CAN, the codes are also in the manual.
 
1 - 4 of 4 Posts
Top