Skyline Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
as you know i have been experiencing quite a few problems recently but his one takes it...

water pump was leaking so bought new one. my mate has a garage (proper garage, not back street. he has fully experinced/qualified mechanics. been using him for 15 years) and he does all works for me as long as i supply parts.

i bought pump and was fitted. but within 1/2 an hour of running to test... it blew up.
and not exagerating here,,, it literrally did that. the front completely blew off, casing fractured, thus putting fan into raditor and destroying that and its surround as well.
never heard of this B4.

on contacting supplier thay stated it was a classic sign of overtightening the belt. but i am sceptical as the belt did not feel that tight as i was there at the time and looked at it b4 hand.
problem is thay are blaming each other and now i have had to buy a new pump, but they want £270.00 for a new radiator and will take 3-4 weeks delivery!!!
i dont think i should pay for any of this, but also feel sorry for my mate.
who should pay?
and can any one get new innards for this radiator? or one similar to fit?

please help

one pis*ed off skyline owner.
oh yeh,, total cost to date in last 3 weeks £1,409.71!!!
now broke.
 

·
Banned
Joined
·
8,850 Posts
I thought the timing belt run the pump ? If so you cant over tighten if you set the tensioners as per factory settings / schedule
 

·
Registered
Joined
·
3,716 Posts
Abbey will likely have a rad in stock mate, they did when Eddie and I needed one
 
N

·
Guest
Joined
·
0 Posts
sorry 2 hear this , sounds like a faulty casting. Yes you can get the rad rebuilt , serck intertruck , i dont know if they are nation wide .
 

·
Registered
Joined
·
704 Posts
take a look on the for sale board tigger I think has an uprated copper one going for £100. Might be a b it cheaper.

Good luck, don't let the bastards get you down.

Matt
 

·
Registered
Joined
·
43 Posts
Discussion Starter #7
cheers guys...
got a new pump and trying to get it under warranty.
hopefully getting radiator re-cored as per your suggestions. been quoted £100.00. but still dont think i should pay for any of it.
the timing belt does not run the water pump, but your right, the cam belt has factory set pre-tensioners (so in theory you cant get that bit wrong! mmm.).
will let you know of out come.
 
1 - 7 of 7 Posts
Top