Skyline Owners Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
386 Posts
Discussion Starter #1
Anybody have a good solution?

I'm assuming they're blocked simply because nothing is coming out and the tank is full!
 

·
Super Moderator
Joined
·
8,969 Posts
Depends if you can hear the pump running or not, if you can try pulling the pipe off the jet and see if it flows, if it does the jet is blocked....try a needle or pin to unblock.
 

·
Registered
Joined
·
354 Posts
When I worked in a garage we used to pull a strand out of a wire brush and stick in the the jet. Works better than trying to blast in out with a airline
 

·
Registered
Joined
·
386 Posts
Discussion Starter #4
Thanks guys I'll try those tomorrow, if memory serves in retrospect I think I noticed it was weaker for a while before it went you know..
 

·
Registered
Joined
·
386 Posts
Discussion Starter #5
Hey guys I think it's the pump, I can't hear it at all. Never had a pump go on washer jets before, is it an easy fix?
 

·
Registered
Joined
·
354 Posts
As above check fuse. But yes the pumps a easy job. It's on the side of the washer bottle just unplug and pull it out the bottle.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #8
I've not checked the fuse, in fact I've not looked at any fuses on this car yet . Where is the fuse for the washers? My 5series had 2 fuse boxes?
I'll check the pump aswel I heard it might work if I give it a tap
 

·
Registered
Joined
·
386 Posts
Discussion Starter #9
Realised it's sneaky hiding place, silly question but it's I've never had these on other cars.. Do I just pull these plugs out yes? Get underneath them and pop them out?
 

·
Registered
Joined
·
1,191 Posts
Just get a flat headed screwdriver under the centre piece lift up about 10mm then it will all come out together, there very brittle though so don't be shocked if you break the odd one or two,
 

·
Registered
Joined
·
386 Posts
Discussion Starter #11
Ok cool if it's still late when I get home tonight I'll get in there and change the battery at the same time. Fingers I don't have toouch trouble, I think my battery is super low aswel secretly hoping changing it will make a difference.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #12 (Edited)
Ok I got in there and then realise 3 things 1 there aren't many fuses there 2. I don't know which fuse is for washer pump & 3 I hope it's not the pump because I don't think I'm skilled enough to get inside the wheel well

Battery changed though.. Didn't fix any of the problems I hoped it would
 

·
Registered
Joined
·
449 Posts
Imgur: The most awesome images on the Internet

Try the fuse mentioned here, if its not that, checkfuses in all 3 fuse boxes: one in drivers footwell, one infront of battery and one behind the battery

If nothing then, you could always try testing the pump by takin a direct supply from the battery to the live and neutral of the pump and see if that makes the motor run. If this didnt work;

I also saw a suggestion that someone with a g35 in america had got his pump clogged and having someone try usin the pumps whilst you hit the side of the pump can unclog it. Maybe worth a try?

Finally, you tried checking clogs in the pipe work? Could also possibly back up and stop the pump???

Not an expert, just a few troubleshooting ideas
 

·
Registered
Joined
·
386 Posts
Discussion Starter #14
Imgur: The most awesome images on the Internet

Try the fuse mentioned here, if its not that, checkfuses in all 3 fuse boxes: one in drivers footwell, one infront of battery and one behind the battery

If nothing then, you could always try testing the pump by takin a direct supply from the battery to the live and neutral of the pump and see if that makes the motor run. If this didnt work;

I also saw a suggestion that someone with a g35 in america had got his pump clogged and having someone try usin the pumps whilst you hit the side of the pump can unclog it. Maybe worth a try?

Finally, you tried checking clogs in the pipe work? Could also possibly back up and stop the pump???

Not an expert, just a few troubleshooting ideas
Been away for a bit and just seen this will check the other fuse boxes too. And yes I saw the tapping tactic. Thanks

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
386 Posts
Discussion Starter #15
Ok after checking everything I think it's definitely the pump. Does anybody know where I can get the correct pump from? Is it same as a Z or same as another Nissan model?

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
386 Posts
Discussion Starter #16
Turns out my pump was gone & i had a blockage (which was great fun to look for). Guessing the blockage caused the pump to work extra hard and knackered it

Sent from my SM-G935F using Tapatalk
 
1 - 18 of 18 Posts
Top