Skyline Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm new to this page so I'm sorry if I've posted in the wrong place. I recently noticed my r32 gtst, rb20det is acting up. I noticed if I clutch in while I'm actually rolling (Say rolling up to a red light clutched it.) That it randomly drops to about 400 revs then comes back up to 1500 (the normal idle) Relatively quick (this doesn't happen while car is not rolling). It's not causing any problems I just have no idea what causes something like that. Cheers Corey

list of mods:
rb20, 60,000kms
Kinugawa T67-25g non anti-surge with high mount mani
38mm TiAL Wastegate
China forward facing plenum
740cc injectors
TS Fuel pressure regulator
Front mount intercooler
HKS cams
3" exhaust
Lightened flywheel
Heavy duty clutch
Shimmed R200 diff
Bosch fuel pump 255
Nistune ecu
 

·
Anglian Area Rep
Joined
·
4,549 Posts
Dump valve can cause issue.
Also easy way to set your idle....
Unplug the wires to the ICV
Car will run like ****.
Adjust the idle screw till it's running smoothly.
Plug the cable back in to the ICV.
The ecu and valve will now control everything nicely.

I had a very very similar issue to your describing and since I done the above I've been fine :bounce:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
I cleaned it out a month ago, and everything seemed fine when I took it apart. I may buy a new one, and thanks I'll try set it with the icv unplugged today. Cheers guys, I'll mess around with it.
 
1 - 5 of 5 Posts
Top