Skyline Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
Ive been trying to locate a problem i got with my Rb25Det Neo Engine, warm and sunny days the car usually runs fine, pulling good up to like 4500 rpms then it feels a bit tired but it goes away when i come over 5500rpms, but on the nights when the air is colder at around that rpm the car goes down to like 4 or 5 cylinders and again it goes away if i manage to get over 5500rpm.
most of the engine is standars, except exhaust with decat and bigger IC, i fitted a boost gauge to check if perhaps i was boosting to much, but according to that i never goes over 0.8bar, the boost pressure seems steady so shouldnt be any pipe leeking i think, also changed spark plugs and knocked em down to 0.8mm, also bypassed the knock sensors with the resistor trick to see if any of those were beeing stupid, checked coils but they looks as good as new. i had a leak at the downpipe but its fixed, fitted a air/ fuel gauge but its kinda hard to read cause of a turbo engine :(

all tips are welcome
 

·
Registered
Joined
·
3,716 Posts
You have the wrong spark plugs
 

·
Registered
Joined
·
85 Posts
Discussion Starter #3
okay, the engine had the standard plugs in it when i got it, i changed to ngk bcpr6 i think the name was, guess ill have to bite the dust and order some iridiums then
 

·
Registered
Joined
·
8,411 Posts
Try plugs first mate! It´s the cheapest way to find out. If not it´s your coilpacks I think. You have ignition problems, the rpm-specific problem you described. Sure you´re overfueling too. And when air is getting colder even more overfueling, therefore more problems...:cheers:
 
1 - 4 of 4 Posts
Top