Skyline Owners Forum banner

1 - 7 of 7 Posts

·
User of V-power
Joined
·
1,112 Posts
Discussion Starter #1 (Edited)
Changed Spark Plugs now got a Backfire?

Hi Peeps,

I Changed my spark plugs this afternoon and replaced my coils with a set that I have cleaned up and insulated (as per "the Guide") all went ok, new plugs in (BKR7EIX) and the car is now running better than ever, no holding back just smooth up through the revs... ok I thaught then I hurd what sounded like a stone hitting the car as i was slowing down (foot off the loud button!) so a I get this a couple more times on my way back home, (never when accellerating only after letting off). so i get home and give the car a rev on the spot and sure enough about 2 secs after letting off the acc "POP!" so the car is now backfiring, this is a little worry'in as i also still have the CAT attached, so the flame and pop thing is a little unexpected?

any ideas as to whats happend? new plugs missing but not under load? dodgy plug? as i say the car is running much smoother with the new plugs in.... apart from the bangs!

Cheers
Dazzler
 

·
User of V-power
Joined
·
1,112 Posts
Discussion Starter #3
Yea i was thinking that, although as i say the car is running soo much better it is unreal, it pulls right the way through instead of holding back between 4500-5500,

I just got back from picking my GF up and it diddent backfire once (20 mile round trip) so maby it was "settling in...." :p

going to get some spitfires soon me thinks... now where did i put oilmans email address... :D

any other ideas welcome!

Cheers
Dazzler
 

·
Registered
Joined
·
1,237 Posts
I woudl have thought that was just Overfuelling, mines(without teh cat) Pops Bangs and shoots falmes on every gear change...
 

·
User of V-power
Joined
·
1,112 Posts
Discussion Starter #7
cheers guys, sounds like all is ok. Just diddent expect it with the cat on.

ATB
Dazzler
 
1 - 7 of 7 Posts
Top