Skyline Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
Im haveing some issues with my turbo setup. Im using 2 t3/t4 turbos on a RB25. The car has been tuned and running 17psi and making just under 400rwkw. The turbos have done about 6000ks work.

When it comes up on boost it makes a choof type noise and the boost guage flickers up and down and the car stops pulling. This problem has only just started happening but doesnt happen all the time.

If anyone with a twin turbo setup has had the same problems or any of the guys making big power can give me some ideas on how to fix the problem that would be awesome.

Cheers,
Rob
 

·
Registered
Joined
·
149 Posts
Discussion Starter #2
so noone else has had this problem???
 

·
Registered
Joined
·
1,039 Posts
Quite common on RB's with large twins. Caused by one turbo producing boost before the other due to inlet tract restriction differences, and/or exhaust pressure differences.

Common cure is to link the two manifolds with a balance pipe.

Mapping also has a big effect on how bad the problem is.

But best solution is to fit a big single:D
 

·
Registered
Joined
·
149 Posts
Discussion Starter #4
There is a link between the 2 manifolds like a Y piece with the 48mm wastegate at the bottom.

What big single would you recommend??? T88 or T51R :)

I want atleast 400rwkw
 

·
Registered
Joined
·
1,039 Posts
No those are too big for 400rwkw, a T04Z is the one you want. Good for upto around 480rwkw.

Probably a Garrett GT35R might get you there too, with a lower boost threshold.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #6
I will have to look for some prices of a T04Z.

I am after all top end power as i want to use this mainly for drags.
 
1 - 6 of 6 Posts
Top