Skyline Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
My r33 gts-gt(sedan) distributor is damage I think, if I use da car will it damage other parts of th engine.?
 

·
Everybody knows that the bird is the word
Joined
·
9,198 Posts
You think its damaged? What exactly is it doing/not doing?
Need a bit more detail than that.....
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
I already change all the ignition coil n spark plug, adjust timing, and still dosent run smoot,,. Pls help. .
 

·
Everybody knows that the bird is the word
Joined
·
9,198 Posts
This is probably a bit obvious but are the plugs gapped correctly? I think you would need a 1.1mm gap.
Im sorry I cant help ya out as far as the dizzy goes, all skylines I have owned have had coils. But it may not be an ignition problem, blocked fuel filter or even a failing fuel pump could give you issues. Possibly an AFM issue too.
If you can give details about what the car is doing, you said it doesnt run smooth.... I assume its missing? Does it do it at idle/under load/at high revs etc?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
When stoping da car the engin wanna stop,also there is a clicking sound under enging when moving on grable. . .tar road no clicking sound.
 

·
Everybody knows that the bird is the word
Joined
·
9,198 Posts
Well if your distributor cap have been damage and you used it. it probably don't work. Symptoms include an engine that will not start, or stops and will not restart...
Umm... thats great n all :confused: but the thread is over 6 months old.... I am pretty sure the problem would have been sorted by now and I really doubt matr33 is even looking here now.
 
1 - 6 of 6 Posts
Top