Skyline Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Hi guys

I think i've floaded my engine, it won't start just keeps trying to turn over but its just not firing. i've taken the plugs out and given them a good clean. The Spark plug that came out of the first cylinder was covered in what looked like carbon. but it still wouldn't start, then tried to start it with the fuel pump fuse out to try and clear any fuel.

Does anyone know of any other way to clear the problem, or what why it happened, as it just cut out as i was going around a roundabout without warning and hasn't started since.

could to much oil in the sump cause this as i think there is to much alittle to much as i my have but to much in due to a bad leak from the turbo's.

cheers
 

·
Registered
Joined
·
116 Posts
Discussion Starter #4
not tried either, will get a tow tomorrow. any idear how to test if fuel is getting in and what caused the floading.
 

·
BEDFORDSHIRE......
Joined
·
999 Posts
If any engine is flooded heavily then the plugs would be wet with petrol. In some cases very wet. I dont think it sounds like flooding. It sounds like the plugs need changing mate? If they were plastered with carbon deposits then it would suggest the car is running rich (not enough air intake) Have you checked the air filter? if this gets clogged then it would make the plugs turn black. BUT! I would start with a air filter check then new plugs and a fuel delivery check.
ALSO. If you take the plugs out give the car a few good turns with them out. This will clear the bores.
HTH

vini
 

·
Registered
Joined
·
610 Posts
same happened to me... i just got my car pulled while in gear for about 50 meters. it then started right up!
 
1 - 6 of 6 Posts
Top