Skyline Owners Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #1 ·
Hi all!

I got myself a lovely R34 GTT last Friday! Love it to bits. I cant stop laughing, feels great owing smug M3 owners as I did today teehe.

Anyways, hopefully this week I'll be taking it to a specialist garage near me to have everything checked over and spot any obvious probs (all seems fine, only 39k on the clock too).

One thing I've noticed though is the odd bit of hessitation through the rev range. often it seems to do it around 5k in 3rd - will sit at that position for say a second then move up smothly again, but I've noticed it at other positions and gears too.

could this be turbo lag? even though the boost gauge is already up and consistant?

Also when I get to around 120mph the car seems to stop acclerating much and the hesitations are more frequent. my mates went to 160 with ease and says mine may have a spee limiter on it? is this likely to be the case and if so will the garage be able to remove this for me?


Obviously the above speeds and tests are carried out on a private track.

Many thanks for any helps!
 

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #2 ·
Hmm just been looking around and spotted this thread:
http://www.skylineowners.com/forum/showthread.php?t=64649

they talk about the last 1k of revs being a lot stronger - this is the kind of thing thats happening to me, a massive boost in the last 1k of RPM before one changes gear.

only they are referring to a 33. My car has a Blitz exhaust, air intake and dump valve - could this be causing some sort of fueling/exhaust temp issues that might cause this holding back?
 

·
Registered
Joined
·
105 Posts
Yeah i know a guy with a G35 who is also limited to 120 MPH, so thats the lickly cause of that one, and as amo said check your coils and spark plugs for the hesitation.
 

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #6 ·
No idea tbh as I only just got the car. Wouldnt suprise me if the plugs/coil packs have never been replaced though. It's done 39k miles.

hopefully the garage will be able to me on the health check.

Are spark plugs/coil packs expensive? Any obvious recomendations for which ones I should get?

Many thanks for the help
 

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #8 ·
Nope, I think due to the blitz exhaust, intake and dump valve its running a bit more. On the boost gauge it gets to about the 10 O'clock position. about 0.8 kg/cm I guess? Will this be effecting things much?
 

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #9 ·
news news news

OK update;

Today I took it to a local specialist who checked the car over, everything seems fine - ignition timings where adjusted slightly that was about it. Also installed an apexi air filter as the one I had on was ganked up. the car does seem noticeably smoother but there is one distinct flat spot which I can recreate almost every time.

in 3rd, just before the revs reach 4k they will stop rising for a second, once or twice the needle kind of blipped back *down* a tiny bit, then a second later it carries on fine again.

The same thing happens in 4th gear just before 4k as well.

1st and 2nd seem fine. either that or its hardly noticeable due to the speed in which the revs climb anyway in those gears

Does this give anyone any clues as to what this might be? boost seems to be around 0.8 but stays constant so i dont think its that causing the "blip"

could it be sparks/coil packs? ECU fuelling issue? somthing more sinister?


Any suggestions of what to try next most appreciated :D I just wanna get her running as good as possible as she is now before I mod for more power or anything :)

Cheers
 

·
Registered
Joined
·
1,859 Posts
Hi RichR34.

Right where to start. Erm with your flat spot question.

You are right. It is perfectly normal for the needle to show a dip in acceleration around the 4krpm mark. Up to this point the Neo Straight six has been doing all the work and then it gets a little kick up the backside from the turbo.

Is your car limited? Easy way to find out. Nail it in a straigh line. If it is limited when you get to 112-120 on the speedo it will feel like a parachute has opened and you will hear the engine cut out until you are below the 112mph mark once more.

Misfire around 5rpms when wanting to go faster than the speed of sound...Had this problem. Changed spark plugs to a heat rating of 8 (which should be done before anymore mods are added I would suggest). I was good for a few months then the car started to misfire again. Checked the coil packs. They were spotless. Then misfire dissapeared for a while but I had already ordered new splitfire coilpacks. So I have put them on and I am really happy with them.

Smoother idle. Much smoother through the rev range and car just sounds much happier.

Remember when you are doing mods to always disconnect the battery and press the brake peddle a few times to reset the ECU. Once mods are in place reconnect the battery and go for a spirited drive. It will relearn everything taking new mods into concideration. Clever things Skylines :)
ps. Park it on a flat raod and in a straight line. All four wheels need to be pointing straight forward because it will need to relearn the HICAS too. Car wont drive in a straight line otherwise :)

Sparkplugs = HKS £88 (RisingSunPerformance do a cheaper alternative with good feedback I have heard)
Splitfire = Around £300 if you shop around

:cheers:
 

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #11 ·
nice one, thanks for clearing up the 4krpm thing, will grab some plugs and coil packs soon and see what happens ;]
 

·
Registered
Joined
·
2,142 Posts
Discussion Starter · #12 ·
Hmmm this site seems to have good prices on plugs:

http://www.carsparkplugs.com/ngk/

only which model number do I need? the chart is confusing? Apparently I want ones gapped to 0.8 with a heat rating on 8, iridium ones?
 
1 - 12 of 12 Posts
Top