Skyline Owners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all, so ive recently bought my 1993 (series 1) r33 gtst auto and for the first few weeks was running sweet then mate decided to block off the bov and i noticed like 5 minutes later itd stall while driving it but still seemed to run fine so i unblocked it then a week later it just decided to not run nicely took multiple attempts to start would idle like it wants to stall and sometimes did and when driving it wont go past 2psi and wont accelerate at all underload even revving standstill it will studder and seem like its starving for fuel ive also got a mate with a manual series 1 ive been using his parts so tried his cas,tps,afm,o2 sensor, 800$ coilpacks and plugs and looked for vaccum and boost leaks everywhere the only other things i can think itd be are fuel injectors and fuel pump which the guy i bought it off only put in a day or 2 before i bought it because apparently the old one died sorry this is so long but yeah any helps appreciated
 

·
Registered
Joined
·
4,436 Posts
You say no boost leaks but I had two split hoses, couldn't find them until I pressure tested the inlet system to 2bar, even though I'm only running 0.85bar of boost. They caused me issues for close to 6months before finding them so I'd try it as a first port of call
.
.
Mikeyp @ TMS Motorsport
Email us : [email protected]

TMS Motorsport - Mintex Brake Pads. Road - Track - Race - Online Shop
- We ship worldwide to your door, famous Brands such as -
- AP Racing - ASNU Injectors - HKS - Nitron - Mintex Pads -
- Turbosmart - Exedy Clutches - Deatschwerks - Cosworth -
- Pagid Pads - Japspeed - Direnza - and many more...
 
1 - 2 of 2 Posts
Top