Skyline Owners Forum banner

1 - 4 of 4 Posts

·
Naz Ali
Joined
·
1,503 Posts
Discussion Starter #1
my r33 rb20e is taking a lot of fuel..way more then my mates 300bhp r33 gtst..

So now i know i got fuelling issues but dont know whats the cause, before i thought all skylines were this bad on fuel but my mate mustang gt v8 is getting better fuel...i always run it on vpower only..as with any other fuel it feels jerky a bit lumpy when setting of and at low speeds but vpower its fine..

I fillup a bit over £20 worth of fuel and i get 50-maybe 60miles before its totaly empty and thats with normal sensible driving...

Plus it regularly shoots out pure blue flames sometimes like a metre long if its very hot...only mod its got a decat and aftermarket 2.25 bore exhaust but fuel consumption was this bad before exhaust and decat

It get serviced every 6mnths...spark plugs, filters,oil change gtx 10-40..even recently serviced gearbox,diff, antifreeze, new brakes discs/pads fluid change, new clutch, crankshaft oil seals, new shocks,spings, rod ends, tyrer..i always let it warm up on start...so i do take care of it only problem i can see is very slight rocker gasket leak and squeal from one of belt...

someone please help me with this, iv listed as much info as i can about my car
 

·
Everybody knows that the bird is the word
Joined
·
9,198 Posts
Plus it regularly shoots out pure blue flames
This tells me it's running ridiculously rich, one of the common causes to run that rich is a faulty coolant temp sensor.
A faulty O2 (lambda) sensor can play a part in running rich too but I don't think to the extent of using as much fuel as you are.
However, both sensors may be faulty!

edit - don't stress either mate... if that is the problem, it's a very cheap and easy fix you can do yourself :)
 
1 - 4 of 4 Posts
Top