Skyline Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Can anyone help me? my car is basically quite standard at tha mo but i keep getting problems with the performance, when the engines cold or just warm it will boost really well and the car flies, but then when it warms up i lose alot of power! its really noticable, boost is still up on guage but the car just seems to be being held back by something badly! please someone help!
 

·
M's Factory
Joined
·
5,240 Posts
try it without flooring your foot to the floor and tell me if it does it still.

Half way will give you full boost and should have the problme, let me know if it is this ?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
its just the same, if your driving it quickly when its going well you can notice the change really badly, ive heard like something electrical moving when the powers cut down before! some days its ok though and then other days its a nightmare, its doing my head in.
 

·
M's Factory
Joined
·
5,240 Posts
Might be the Variable Valve Timing changing.
 

·
M's Factory
Joined
·
5,240 Posts
Well you say your car is kinda standard. errr STandard plastic turbo ? Wound up boost ?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
standard turbo and standard boost! its just pissing me off cos its great when its cold, really flies then this happens and i get bored with it!
 

·
Needs a self cleaning car
Joined
·
1,455 Posts
Call Abbey Motorsport

01883 732331

They're in Oxted, Surrey.

Also suggest putting a post on the GT-R register (www.gtr.co.uk) as there are several R34 GTT owners on there.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #9
cool cheers jae! il give em a call. Watch this space, i may have some good power back again soon!
 
1 - 9 of 9 Posts
Top