Skyline Owners Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1 (Edited)
gts4 fuel pump

Hi I've got a 1991 r32 gts4 and a problem has just started. The problem is on idle the car will only rev to 5k and then drops back down, when driving it only goes to about 3k and constantly pops and throws flames and has no power. I don't no what to check so all the help will be appreciated.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #4
the car started in the morning but after about a minute it wanted to shut off so i had to keep my foot on the gas, iv changed the AFM for a good working one but now it just dont want to start. the car is all standard apart from the exhaust and a RSP ecu.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #6
It doesn't sound like a good working afm if now the car won't start at all. Unplug it and see if the car then starts again.
the car wouldn't start before i changed the AFM, iv tried to start it with the AFM unplugged but no luck. all i can smell if fuel. s it might be flooded, why will it get flooded. iv tried to get a fault code but keep on giving my 55 )no fault)
 

·
Registered
Joined
·
112 Posts
Discussion Starter #7
iv just checked to see if it is getting any fuel and its not getting any.

could it e the fuel pump or the fuel regulator. and how can i check which one it is.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #8
iv just tested the fuel pump and it is dead. can anyone recommend a fuel pump, my car is standard.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #11
How did you test the pump?
It could be the CAS that's died.
CAS is fine. i tested the fuel pump by connecting it directly to a battery and nothing happened, then i took the pump out of my BMW and done the same thing and the pump was working finally i had put the BMW pump in my R32 and she had started straight away. so in know it is the pump for 100%
 

·
Premium Member
Joined
·
2,723 Posts
CAS is fine. i tested the fuel pump by connecting it directly to a battery and nothing happened, then i took the pump out of my BMW and done the same thing and the pump was working finally i had put the BMW pump in my R32 and she had started straight away. so in know it is the pump for 100%
Good answer! :bigthumb:
 

·
Registered
Joined
·
112 Posts
Discussion Starter #14
can anyone else recommend a fuel pump to me, my car is standard apart from the exhaust. also im not planning to do any mods to the car it will stay standard.

all the help is appreciated.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #16
where the best place to get one from i dont really want to spend too much, and if i put a gtr one in is it a straight fit, will the ecu need to be retuned and will i need a FPR. when it come to these things im a bit dumb
 

·
Registered
Joined
·
112 Posts
Discussion Starter #18
All sorted, no hesitations, flat spots.....

to help others the thing i had done.
cleaned the fuel pump
new fuel filter
after doing this the car ran fine for about 10mins then just would not go past 2.5k, then i had resoldered all the joints on the AFM took it for a blast and all good.

iv only had the car for about 3 months and it has never driven like this before.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #20
about 2 months later the car started playing up again.

when i drive the car on full throttle it will start popping hesitating and jerking very very bad, it will happen when the car is cold or warm and after a while the car just wants to shut off.

i thought it might be the afm but have changed it once, but changed it again before changing it i had re-soldered all the joints and give it a clean with brake cleaner. that made no difference.
know i dont now what to do so all the help will be appreciated.
 
1 - 20 of 20 Posts
Top