Skyline Owners Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
243 Posts
Discussion Starter · #1 ·
hi all
i fitted a aftermarket bov this morning the car ran fine untill i was comeing home from work, it was running fine then i went to put my foot down it judded then i lost most of my power so i pulled over to check none of the boost pipes had come off, i couldn't see any that had so i gave it a quick rev and out came a cloud of smoke (out of the exhaust) it looked grey but it was dark and smelled like oil it doesnt smoke on idel but as soon as i touch the accelerator it smokes like hell the standard boost guage moves off of the bottom but wont go above the 0 mark.
is this the turbo or is it rebuild time and oil pressure was normal.
thanks
gav
 

·
Registered
Joined
·
781 Posts
the same thing happened to be yesterday!!
my turbo went bang doing the same.. smoking on revs not idel, oil pressure ok, oil temp ok etc.
removed the turbo today and found the exhaust side of the turbo in the back box and the inlet side of the turbo in the intercooler!! lucky as hell i did not take out the engine
 

·
Peppered schlong
Joined
·
860 Posts
Alright Gavin, is there any oil coming out of the bov?
 

·
Registered
Joined
·
60 Posts
i couldn't see any that had so i gave it a quick rev and out came a cloud of smoke (out of the exhaust) it looked grey but it was dark and smelled like oil
gav


just read it again grey smoke.

i had blue smoke comin out of mine thought it was the turbo so i spent 2k on upgrading my turbo with external wastegate,dump valve and some other bits and bobs.
thought it was fixed took the car out and loads of blue and white smoke come out, so i took the head off had it pressure tested found out that i had cracked the head.
so i would check everythink before you spend any money.

does anyone know of any body with a head for sale? rb25det
 

·
Registered
Joined
·
243 Posts
Discussion Starter · #9 ·
ive had the pipes off and i cant see any oil but if the seal gone on the exhaust side i wouldnt would i it deffinatly smells like burning oil from the exhaust and there is no spool at all.
thanks
 

·
R33 GTST Owner.
Joined
·
244 Posts
Sounds like a boost pipe coming loose at first as i blew an intercooler pipe of my starlet turbo and it got some strange sounds and wouldnt move the gauge but no smoke like you say.

Turbo imo.
 
1 - 10 of 10 Posts
Top