Skyline Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys, I need a little help, my skyline's HICAS isn't workin correctly, if you start and drive the car its fine but after about 10 mins the steering gets heavy and then the HICAS light comes on, I've had a diagnostics check done and nothing comes up, does anyone know how to fix this problem or why it is happening,
Cheers
 

·
Registered
Joined
·
760 Posts
Personnally i think the hicas system is s**t, my opinion would be rip it out and put a locking bar in there and never worry about it again, more hassle than what its worth! Other people will say different, but maybe they have never experienced faults with it!
 

·
Registered
Joined
·
34 Posts
my hicas light comes on when im on a straight road for a long time (motorway, etc) it goes after a while. i did query this and have been told that its nothing to worry about.
 

·
Super Moderator
Joined
·
9,426 Posts
it could either be faulty hicas ecu, no speed signal to the ecu or steering angle sensor.....

does it have an after market steering wheel?
 

·
Registered
Joined
·
334 Posts
It's prob the speed signal. When you first start up and drive the hi-cas needs a speed signal, it will take about 10mins or so before it realises it's not there and the light comes on.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
it could either be faulty hicas ecu, no speed signal to the ecu or steering angle sensor.....

does it have an after market steering wheel?
Ya it has a Nismo steering wheel, how do I find out which of those it is, also does anyone know of any Skyline specialists in the south of Ireland, if I ever needed something done that I can't do myself I don't want to give it to some clueless mechanic who has probably never even seen a Skyline before nevermind worked on one!
 
1 - 9 of 9 Posts
Top