Skyline Owners Forum banner

1 - 20 of 61 Posts

·
Registered
Joined
·
952 Posts
Discussion Starter #1
for some reason my top end is struggling im hittin about 100 at 4500 rpm but after that the speed barely goes up now. it almost redlines at 140. whats wrong with her?
 

·
M's Factory
Joined
·
5,240 Posts
change gear ? :)
 

·
Registered
Joined
·
953 Posts
should be good for more than that mate have done about 160 plus in mine
 

·
M's Factory
Joined
·
5,240 Posts
maybe your speedo is reading wrong and your previous speed was incorrect and now is ?

Does the car feel slower ?

Have someone else drive next to you at a specified speed and see if there is a huge difference in your terminal speeds. ie one of you is pulling away or lagging behind ?
 

·
Registered
Joined
·
952 Posts
Discussion Starter #7
the car does feel slower now top end. its like the revs are going up but the car aint moving
 

·
M's Factory
Joined
·
5,240 Posts
CLutch.
 

·
M's Factory
Joined
·
5,240 Posts
travelling at 140mph i doubt there would be, not all clutches slip and give smell unless you sit and rev the bo11ox out of them mate.
 

·
Registered
Joined
·
953 Posts
i was thinking cutch slip maybe
 

·
Registered
Joined
·
952 Posts
Discussion Starter #13
ive thought of numerous things. gearbox,clutch,loss of power but its like its happened literally over night
 

·
M's Factory
Joined
·
5,240 Posts
20k on a clutch can go in 1000 miles depending on how you drive it.
 

·
M's Factory
Joined
·
5,240 Posts
if the revs are climbing and your not going anywhere then its clutch, end of story.

Go out at lunch get into 3rd or forth gear and put it to the floor at low revs.... if the revs climb and then climb more than your accelerating then its your crutch....... ;) its worn out too much use.
 

·
M's Factory
Joined
·
5,240 Posts
well try it and come back and let us know then if it does it you know if it doesnt then its something else.
 

·
Registered
Joined
·
952 Posts
Discussion Starter #19
well i tried the old second gear stationary clutch thingy. and it bit straight away
 

·
M's Factory
Joined
·
5,240 Posts
thats not on boost... hardly any power / torque... do it as i asked :)
 
1 - 20 of 61 Posts
Top