Skyline Owners Forum banner

1 - 12 of 12 Posts

·
this is me take it or do one....that simple
Joined
·
4,082 Posts
Discussion Starter #1
hey lads after going to mgt last night its really bugged me how my car was seriously misfiring between 4000 n 5000RPM garth changed the spark plugs for iridium ngk's then tryed a set of second hand coilpacks but again it was misfiring between the same rev range and this cant be a coincedence that both sets of packs were gone so has any1 else experianced this before as my car did msfire when i 1st bought it but wasnt that bad BUT i noticed it did misfire more when i changed the turbo to hybrid but surely the turbo cannot cause the enging to misfire????

any help will be appreciated as i feel down in the dumps over this as i wanted my car to be mapped n all sorted yesterday:disappointed:
 

·
Banned
Joined
·
1,743 Posts
I did experience something similar, but was running standard tubbies and injectors, mine turned out to be a combination of a dodgy coilpack and dodgy MAF, with fubar'd platinum plugs, diagnosed by the wonderful Abbey Motorsport, who leant me a coilpack and MAF to get home and then fought with my warranty company to get replacement new bits for the car :D
 

·
this is me take it or do one....that simple
Joined
·
4,082 Posts
Discussion Starter #3
I did experience something similar, but was running standard tubbies and injectors, mine turned out to be a combination of a dodgy coilpack and dodgy MAF, with fubar'd platinum plugs, diagnosed by the wonderful Abbey Motorsport, who leant me a coilpack and MAF to get home and then fought with my warranty company to get replacement new bits for the car :D
hmmm thanks for info... mate
 

·
Registered
Joined
·
191 Posts
i had same problem with mine changed coil packs and it was almost gone then got worse again over time turned out to be MAF was failing mostly did it when was warm, then one day just chucked its toys out the pram and give up!
 

·
Nottinghamshire Area Rep
Joined
·
895 Posts
mate it will b ur maf, they tend to fail at high revs, wot u runnin? z32afm? if not get one of them on it mate.
 

·
this is me take it or do one....that simple
Joined
·
4,082 Posts
Discussion Starter #6
mate it will b ur maf, they tend to fail at high revs, wot u runnin? z32afm? if not get one of them on it mate.
no mate ive got standard butive also got z32 but need the plug for it to wire it in to my loom pal
 

·
seeking to be one of thee top DE+t conversions
Joined
·
1,523 Posts
i thought when some maps the car they should see this/that at fault when setting it all up on the good old laptop??? i maybe wrong tho
 

·
Registered
Joined
·
4,045 Posts
i had same problem with mine changed coil packs and it was almost gone then got worse again over time turned out to be MAF was failing mostly did it when was warm, then one day just chucked its toys out the pram and give up!
I don't no how many times I've said it but this ^^^^^^^^
 

·
this is me take it or do one....that simple
Joined
·
4,082 Posts
Discussion Starter #11
Get a plug then mate, book ur car bak in at mgt, fit it then av it mapped mate, u should c a difference:Uzi:
my car is still at mgt ive got there volvo loaner car, a member on here is sorting my out a plug as garth says he needs a plug to wire in my loom then he can fit the z32 which i got from japandyno, so hopefully it will solve the problem and i can have a nice mapped car......
 
1 - 12 of 12 Posts
Top