Skyline Owners Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi everyone, just got myself a 93 r33 gts-t, having, really pleased with it but just got a couple of questions at the mo, before the modifying bug bites :D

firstly the car seems to be hesitatent between 4.5k and 5.5k rpm, i understand that there are two level of boost, it seems to be on about 0.35 bar on the dial up to these revs, and then goes up to just below 0.7, but does seem to be a bit spluttery when it hits 4500 rpm. any ideas ??

also it is stil limited to 112mph, am i right in thinking that i can simply cut one of the wires from the ecu to get past this, and dont have to but a speed delimited ???

Thanks in advance guys, more questions to come when i get into modding it more

Rich
 

·
Registered
Joined
·
469 Posts
Rich,

Has your speedo been converted to MPH - the most common way of doing this is with an electronic converter which leaves the speedo face unchanged but makes it read in MPH instead of KPH. If you have one of these you'll either have no limiter anymore, or it will now be at 180mph instead of 180kph, so shouldn't really cause much of a problem ;-)

Not sure about the spluttering - dirty air filter maybe. Have a search through the tuning forum - you might find some more help on that one.

Good luck.
 

·
M's Factory
Joined
·
5,240 Posts
Welcome to the club Rich, best thing to do as your local is let us have a look at it when your free.
 

·
Registered
Joined
·
3,716 Posts
Good point Sarky,
Or if you'd rather do it yourself, it is likely to be plugs or plug gaps casing the spluttering which seems to be remarkeably common with these. Make sure the plugs are good quality and the gaps are no bigger than 0.8mm

If your still keen to remove the limiter then cut wire #53 to the ecu

Paul
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Cheers for the replys lads, plugs were changed a week ago before i picked it up, so possible they are not gapped correctly, will check that out, along with the air filter,

speedo maxes out at 100mph so assume it is still the jap one, its still recording in kph anyway, was thinking about getting a set of the indigo dials as they read up to 180mph, but then assume that the speedo wont be reading correctly if i do that, would an electical convertor correct this ???, if so anyone know where i can get one ??

Sarky, would be great if you wanna take a look at it, just let us know when

Cheers
Rich
 

·
Super Moderator
Joined
·
9,426 Posts
Rich, we are around most of the time, why dont you pop over to Richard Bell's in Guildford...he is there all this weekend....
 
N

·
Guest
Joined
·
0 Posts
rich , your car should not have passed the esva , if its still reading in kmh. however , if u dont want 2 chip it , which involves taking the dash off , pin 53 on the ecu , will remove the speed limeter .
 

·
Registered
Joined
·
12 Posts
Discussion Starter #10
Cheers lads, have mailed protech about the delimiter, the actual speedo reads in both mph and kph, but the mph tops out at 100 on the dial. as far as i know it is still recording in kph, not sure about pin 53 as i think the delimiter would be a better solution.

Anyone offer any advice about the boost set up, it seems to come on higher boost at about 4500rpm, up till then its about 3.5 on the integral boost gauge, then it goes up to just under 7, is this right ??

Tigger, might pop over on sat, where about is Richard Bell, would be good to meet up with a few people in the know

Thanks for all the help lads

Rich
 

·
Super Moderator
Joined
·
9,426 Posts
I will be at Richards in the morn as my car is over there being worked on. Am sure a few others will be there too!! if you give me a bell on 07739322273 I can give you directions...
 
N

·
Guest
Joined
·
0 Posts
when you get the chip , it will have 4 wires , one is 12 v supply , one is earth , the other 2 you have 2 splice into a wire on the back of the instrument pod.

regards
 

·
M's Factory
Joined
·
5,240 Posts
why not pop down the french horn tonight with us from Berks and we can talk about your problem on a group therapy basis :)
 

·
Registered
Joined
·
43 Posts
welcome my friend.. itoo am a newbie and have too found the dudes here most helpful...
just one thing about ya boost... you lucky git... mine is constant from just over 2,000 rpm to the limit... at bloody 0.4.!!!
me finks i need to TURN IT UP - LOUD!
good luck
 

·
Old Member
Joined
·
814 Posts
Rich,had same speedo problem with mine. Got a s/h speedo from one of the boys and a delimiter from Amber performance, dash not too hard to play with (better done in the warm) and as previously stated four wires, two fixed to back of speedo and two to plumb into the speedo harnes plus one to disonnect completely, job done in 1.5 hours. Hardest part, finding somewhere to go more than 112 m.p.h..... HA.HA.
 
1 - 19 of 19 Posts
Top