Skyline Owners Forum banner

1 - 6 of 6 Posts

·
.......P33 TEX.........
Joined
·
2,230 Posts
Discussion Starter #1 (Edited)
Hey, Just spent most of the weekend (in between looking after my son etc), changing my turbo and elbow/downpipe as you guys very kindly helped my diagnose my cars illness, Thrust bearings broke!


Cue new turbo and Japspeed elbow/downpipe while im at it! looks amazing,


i polished up the turbo a bit and inlet elbow bit.


Noticed that the very front upper exhaust manifold stud has snapped off, damn!
moving on..
Once i finished putting it all back together, took it for a spin, think the exhaust is blowing a little bit by decat but thats not the problem, its making a funny electric 'whine', dont think the boost controller is doing it, its a Blitz sbc id3,

Any ideas? can it really be the one snapped exhaust manifold? boost controller? heater controls? I dont know, At least its stopped spiking now.
 

·
Registered
Joined
·
162 Posts
i helped him with it, took us a while but once you find all the bits and bobs to take of and work out how to get to bolts (i swear they make it difficult!!), its really easy.
 

·
.......P33 TEX.........
Joined
·
2,230 Posts
Discussion Starter #4
yeh, its not too bad actually, the hard bits were putting the banjo's back on! Especially the oil feed one, i'm def changin it to a braided hose next time i take the turbo off?
 

·
Registered
Joined
·
490 Posts
i helped him with it, took us a while but once you find all the bits and bobs to take of and work out how to get to bolts (i swear they make it difficult!!), its really easy.
wanna do mine? haha thanks for the info :)
 
1 - 6 of 6 Posts
Top