Skyline Owners Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter · #1 ·
can anyone help? my r32 aint revving properly and pulls like a metro. its had different maf. coil packs. feul pump and still aint right. any ideas would be really appreciated.
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #5 ·
i got the car like this. the fella i got it off recon the injectors and put new fuel pump on. also he changed the maf. do you think the turbo might be siezed? someone also told me it could be the throttle position sensor?
 

·
Registered
Joined
·
6,068 Posts
Hmm... could be a whole bunch of things.

Are you sure the injectors are correct? Any paperwork for the reconditioning? Normally you get a printout of the flow rates etc...

MAF- is it the correct one for your RB20DET?

Have you checked that fuel is getting to the engine bay?

If you take off the turbo elbow you can visually inspect the turbine wheel. This is ceramic as standard on yours and is very prone to damage/falling off especially if you don't know how the car has been treated previously, i.e. ran at too high boost!
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #7 ·
the maf was bought off ebay and not sure on injectors.
is there any way of checking injectors? im gonna take the elbow off and check the turbo when i can. whats the best way to check if fuel is coming through? its got a fuel pres regulater on it and it blew the o rings in the injectors so thats been disconnected for now.
 

·
Registered
Joined
·
6,068 Posts
To be honest it sounds like the previous owner has been modifying things and messing about with stuff without really knowing what they are doing....

What colour is the MAF label?

Remove the fuel pump fuse, turn the engine over to get rid of the pressure in the lines (very important), then put the fuel pump fuse back in, undo one of the fuel feed lines, get a container to point the hose into, get someone to turn the engine over and see what comes out. But the FPR issue says you have good fuel pressure.

When you say the aftermarket FPR has been removed, has the standard FPR been put back?

If it was me I would try to get everything back to stock and get the thing running right. The start again with the mods ; )
 

·
Registered
Joined
·
6,068 Posts
Have you checked the actuator is still connected to the wastegate?

Whilst you are checking the car out, do take the elbow off and have a look at the back end of the turbo...
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top