Skyline Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter #1
hello all, i have a problem and would appeciate some advise, basicly sometimes when i pull away in 1st i get an odd quick grinding noise as i realease the clutch as far as i know it has a twin plate clutch not sure what brand, the noise only appears intermitantly so as you can guess its pritty anoying. i have just changed the gear box oil didnt seem to bad. any one got any ideas

cheers for any input
 

·
Registered
Joined
·
4,730 Posts
Sorry mate i have no idea as to what that might be, I don`t know much about twin plate clutches having never used one.
 

·
Registered
Joined
·
194 Posts
Discussion Starter #5
hi cheers, doa, just been out in it again and am not sure if it is coming from the box, think something may be binding
 

·
www.bmstyling.co.uk for all your bmw styling needs
Joined
·
147 Posts
i got the same problem from cold but in reverse its like a grinding and i can feel it vibrate the clutch pedal and the gear lever area, once warmed up it goes, im pretty sure its a worn release bearing as the person who had the car before me put a spare clutch in and pressure plate but not a new release bearing as a quick fix but he used it for 6 months and put couple thousand miles on it before i got it... Just a guess but id say its that....
 

·
Registered
Joined
·
95 Posts
I have just had this problem but found out what it was the expensive way. I have the OS Geiken clutch in mine and was making a light noise when the clutch was pressed, also 1st was hard to engage.
Then out of the blue it started to scream when the clutch was pressed, it eventually failed.
Steve from RB Motorsports diagnosed the problem as the cover plate was not reduced by 7 to 8 mm when the clutch was replaced resulting in pressure being applied to the clutch at all times.
Do your self a favour get it looked at NOW.
 
1 - 10 of 10 Posts
Top