Skyline Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
My 2005 350GT developed a serious issues(lost of power, and wouldn't start whilst driving), wioth the eng mngt light on, VDC off and SLIP ligtts on...this happened 2 short drives after changing the oil/oil filter(same ones I've been using for 9 years), I checked the levels and it's at around 90%(just under high level)

Had to pull over and let the car rest before starting again it would come back on but in limp mode.

Got the codes read and it came back with a P0021 error, most likely the Camshaft senor/Intake Solenoid Issues.

It's a 2005 350GT, has anyone had a similar fault, what was the issue? I checked the front variable valve timing (bank 2; passenger side?) and I can feel a little oil around it(gasket gone?) Ordered the solenoids/camshaft/cranskshaft sensor just in case...

Trying to find replacement parts(350Z seems compatible) but no luck in finding them in the UK?

Any help would be appreciated....
 

·
Super Moderator
Joined
·
8,969 Posts
The motor is basically the same and Z parts should be available and interchangeable, cam position sensor failure is a common problem.
Have a look over on the 350Z forum they may be able to point you in the right direction.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
The motor is basically the same and Z parts should be available and interchangeable, cam position sensor failure is a common problem.
Have a look over on the 350Z forum they may be able to point you in the right direction.
Thanks Tricky, will do.
 
1 - 3 of 3 Posts
Top