Skyline Owners Forum banner

1 - 16 of 16 Posts

·
Hello, little lady!
Joined
·
556 Posts
Discussion Starter #1 (Edited)
Right now I'm confused. Anyone who has spoken to me recently about my car will know I'm a little disappointed with my performance at the moment. Specifically 2 problems have surfaced:

1) Losing 80bhp from flywheel to wheels.

2) Engine seems to be "holding back" especially over 5000rpm.

Number 1 I'll tackle by making sure my brakes are all ok (thanks for the suggestion robo) and changin gearbox and diff oils. Then if still shite, get Abbey to look. :)

Number 2 is the interesting one. I tend not to use my boost controller on high boost at the moment (0.8 bar) because I don't trust that things are running right under the bonnet. However I was driving back from Hartley Witney this afternoon, down some country roads and decided to play - so turned controller on and ran on high boost. A second after turning on, something went pop out the exhaust, the car felt like I'd slammed the anchors on (probably something going bad in the engine and forcing engine braking?). This I didn't like so turned the boost controller off and was amazed to find that problem number 2 had disappeared!

The car ran BEAUTIFULLY like **** off a shovel all the way home. However the problem will be back tomorrow when the engine has settled again.

Now. WTF is wrong with my car and how do I fix it?

Any guesses?

J.
 

·
Hello, little lady!
Joined
·
556 Posts
Discussion Starter #3
Still not right.
 

·
Hello, little lady!
Joined
·
556 Posts
Discussion Starter #6
Bllcks. Hope I don't need new injectors. :-(
 

·
Hello, little lady!
Joined
·
556 Posts
Discussion Starter #8
Controller off is the standard 2 stage boost: 0.3 then 0.6 I believe. ECU has been reset several times with no effect.
Low Boost is 0.6, High 0.8.
 

·
Hello, little lady!
Joined
·
556 Posts
Discussion Starter #11
How did you fix jock?
 

·
Hello, little lady!
Joined
·
556 Posts
Discussion Starter #12
I've just been playing with screwdrivers and spanners and the like. Thought I'd try and get the o2 sensor off for an inspection cause Sarky is always banging on about how these always go bad, and last night I saw something about cleaning up with a lemon. Could I get the bloody thing out? Could I Fcuk! So I resorted to pulling my ECU out and running the diagnostics instead. Apparently all is ok. The built it o2 sensor test tells me I'm neither running rich nor lean either which I suppose is pretty good.

Guess my performance problems MUST be down to lack of fuel getting into the engine.

J.
 

·
Hello, little lady!
Joined
·
556 Posts
Discussion Starter #15
Would do if I knew how to. :)

Where is it and where can I get a replacement?

J.
 

·
M's Factory
Joined
·
5,240 Posts
im reading this as I had missed this thread, it sounds like you are hitting the top of your map in the standard ecu to me. The ecu is still controlling the engine and will cut out and reset if needs be at a higher than factory stated boost outside of its mapped ranges.
 
1 - 16 of 16 Posts
Top