Skyline Owners Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi,
I have got a usd FC from japan for rb25.
i have s1 rb25det in r33. when i swapped from standart ecu (unpluged the battery first of all) turn the ignition on and the blue relay in the back near the battery starts going insane, it's the fuel pump relay, yes?
try to start the engine but it doesn't start, swapped back to original ecu, starts and drives very good.
took both covers off, no burn marks or non manufacturing "welds"
tried connecting to a laptop using wire while on ignition. no connection. ecu came without hand controller.

What is the problem, do i need to swap some wires or i got a burned ecu.

Haven't check the pinout yet. anyone got a diagram for power FC?

Thanks
 

·
tdi power
Joined
·
13,297 Posts
if you dont have fc datalogit you cant connect to it using the consult port

you dont need to swap any wires when putting a power fc in
 

·
tdi power
Joined
·
13,297 Posts
there is a wire on the loom that if its not connected up when you do a engine swap to a different car it wont start

someone else had exactly the same problem with exactly the same engine/car swap you had
 

·
RB25det inside
Joined
·
1,253 Posts
I had the same problem when I put a rb25 into my r32.
The problem is the way the eccs relay was wired ,the pfc needs all 3 12v power supplies. Pin 49,58+59
http://nismo-club.ge/docs/RB25DETECUPINOUTS.jpg


With the standard ecu in ,when you turn off ignition you should hear a "click" 1-2 seconds after turning the key off. If that's not happening you're wiring trough the relay isnt right.
 
1 - 6 of 6 Posts
Top