Skyline Owners Forum banner

1 - 10 of 10 Posts

·
Ok Penelope!
Joined
·
382 Posts
Discussion Starter #1
Hi All,

Driving to work this morning, all of a sudden the power steering went. Checked the fluid levels, look fine. Does anyone have any ideas. I think it might be the pump. Does anyone know how much they cost and how likely i am able to get one quickly.
 

·
Ok Penelope!
Joined
·
382 Posts
Discussion Starter #3
Hi Jock Alert

The speedo seems fine, although my rev counter has been playing silly buggers lately.

i'll check the belt
 

·
Registered
Joined
·
2,433 Posts
Could be worthwhile and save some pennies.... I asked about the ecu wiring cos I once buggered up fitting a Blitz power meter to the speedo signal wire from the ecu. The result was a loss of power steering and HICAS until I sorted the wiring (ie got it the correct way round). ANything wired in to the ECU may be worth checking.
 

·
Registered
Joined
·
2,433 Posts
Ahh.... There's the problem. No belt! lol

Belt itslef is probably about a tenner. Fitting requires removing the radiator and a few bit and bobs.

Richard Bell is the man to speak to I believe, he stripped my rad and everything out, fitted a new water pump and rebuilt the lot in two hours. Very reasonable rates too.

I reckon it shouldn't cost you much if its just a few hours labour and a simple belt.
 

·
Banned
Joined
·
8,850 Posts
Check the pump has'nt siezed up and is free to rotate, belts dont snap for nothing unless they are old and never been replaced
 

·
Ok Penelope!
Joined
·
382 Posts
Discussion Starter #10
cheers for your help guys,

I've checked the pump, all seems well. I can only imagine that it was tight enough in the first place.

I'll keep an eye on it
 
1 - 10 of 10 Posts
Top