Skyline Owners Forum banner

1 - 7 of 7 Posts

·
Ex Skylineowner
Joined
·
3,444 Posts
Discussion Starter #1
How does one go about that then? I assume i just syringe in oil down through the top feed slowly until it wont take any more?

:cheers:
 

·
Seasoned Member
Joined
·
21,588 Posts
im no mecahanic james but thats what i would do mate. then start it and let it run on tick over for a few mins mate.....if you pm me yr number ill find out from richard at RSP and text you the correct answer mate im down there tomorrow, if you need to know early ill ring him at 8am.....:)
 

·
bla
Joined
·
17,374 Posts
i primed my tubby by unplugging all coils.... Turn over until the oil light on the dash goes out. When the oil light turns off then plug it back, turn on and check for leaks... :)
 

·
Registered
Joined
·
610 Posts
dont matter much. just refill oil to amounts required. turn car on. exhaust gases aren't hot enough to damage the tub and the bldes wont even be spinning that fast, or at all. after the oil pump has been able to pump oil through the lines after about a min, turn car off and add more oil. let cool for about 30 min, then turn on again. let idle for another 2 min. then turn off and adjust oil once more! :p then this time turn car on and gently rev the car to allow pump to push oil through the twisted oil line to push out the air bubbles. after that, let car idle for 30 min while u clean things up and put your tools away. then get in and drive around for a few miles under little to med load for about a few miles. then stomp the throttle and feel the power!
 

·
Registered
Joined
·
610 Posts
or should i say; the turbo wont get hot enough to damage the tub in under a min of idle.;
 
1 - 7 of 7 Posts
Top