Skyline Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi guys need your help, after fixing a idle problem 2 weeks ago now the car won't idle at all, I'm hoping it's not the fuel pump, what are your thoughts, the car starts and when it comes off of fast idle it dies, but starts every time the key is turned.
 

·
Registered
Joined
·
415 Posts
What was the previous fix? Sounds like they'd be related. There's an idle control valve somewhere:
RB25DET IAC Valve
[without one] "... if you are hardon the gas at all and then you lift your foot off the gas you need to keep your foot on the throttle to modulate the gas as you come down in the rpms. if you fail to do that the car will stall 100% of the time." (4th post)
Otherwise could be something like MAF problem, but I'm no expert.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Yeah it runs with the use of the pedal but won't idle by it's self, and the previous problem was the IAC valve, I changed it and thought the problem was fixed, the car ran like a top, but after letting it sit for a few day's it seems the IAC isn't working at all.
 

·
Super Moderator
Joined
·
8,969 Posts
You may need to check and reset the TPS voltage.
 
  • Like
Reactions: johnr33gts-t

·
Registered
Joined
·
3 Posts
Having the same issue on my R33 - yesterday I was driving and coming to a stop the car would cut out - Cannot let the car idle as it seems to cut off. Now this morning - won’t stay on in idle - using throttle seems to keep the the running. Any help guys?
 
1 - 7 of 7 Posts
Top