Skyline Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey everyone, my cars having idle issues. It stalls out when I'm not accelerating and stays in low idle-- I went ahead and cleaned out MAF sensor, TPS sensor and AAC valve, also did oil and filter and spark plugs... still same issue!
I'm thinking it's a vacuum leak but if anyone has any idea or has came across this issue any help would be appreciated.
 

·
Registered
Joined
·
10 Posts
I have a similar issue on by rb20det. If I rev the engine, it drops below idle and almost stalls but stays alive, but when I drive and pull up to a stop light when its warm it stalls out in the same situation. I cleaned out my AAC and think it's vacuum leak also. Some have said it's a tired ignitor, but I tested it with a multimeter based on a video on youtube and seems fine.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I have a similar issue on by rb20det. If I rev the engine, it drops below idle and almost stalls but stays alive, but when I drive and pull up to a stop light when its warm it stalls out in the same situation. I cleaned out my AAC and think it's vacuum leak also. Some have said it's a tired ignitor, but I tested it with a multimeter based on a video on youtube and seems fine.
well I'm try and figure out if its a vacuum leak this weekend will let you know what I figure out! Thanks for the response. :bigthumb:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hey I figured out what it was, not a hose! MAF sensor needs to be replaces- I had cleaned all the sensors before and nothing changed so when I decided to disconnect the MAF sensor while the car was running it started to idle back to normal. Ordered OEM part from Rivsu $66 with shipping and not my car is running amazing!!
 

·
Registered
Joined
·
52 Posts
Yup, I read your problems, and it sounded like a MAF. These things are trouble. especially at 20+ years old now. Mine is still working ok, I keep it clean with MAF sensor cleaner I bought at advanced auto.

Glad to hear you got it sorted.
 
1 - 6 of 6 Posts
Top