Skyline Owners Forum banner

1 - 7 of 7 Posts

·
Member
Joined
·
4,543 Posts
Discussion Starter #1
Hey All

I have looked hi and low but having no luck finding a wiring diagram of the wiring colours for RB20DET injectors, I want to check they are wired up correctly as some cylinders are filling up with fuel when the pump primes so no fuel pressure as it goes straight into cylinder 5 on prime which is odd as the injectors are clicking on and off if i spin the CAS.

Any ideas? i just wanted to start by checking the wiring, its a full rebuild so everything has been out to a bare shell and now rebuilt.

David
 

·
Registered
Joined
·
415 Posts
Can't help you with the wiring I'm afraid. Are the injectors new / replaced, and / or did you have them flow tested before installation? I have a set of injectors waiting to go in, but since they were lying around for about 10 years I had them inspected. I was fully prepared to find out they were shot, but apparently they are fine!
 

·
Super Moderator
Joined
·
8,994 Posts
If the cylinders are filling with fuel its unlikly to be a wiring fault it will be the injectors stuck open or internal seals failed.
 

·
Super Moderator
Joined
·
8,994 Posts
Yes take them out and turn the ignition/fuel pump on you will soon see if they are leaking its always best to get injectors flow tested even new ones.
 

·
Super Moderator
Joined
·
8,994 Posts
What do you mean by cold start valve? as cold start is handled by the ECU temp sensor and will run more injector duty cycle if temp i s below a certain threshold therefore automatic.

It is VERY unuseual to see lean mix on cold start unless there is an air leak somewhere.
 
1 - 7 of 7 Posts
Top