Skyline Owners Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter · #1 ·
just bought me a R32 gts-t with the rb20det engine earlier this week.
the problem with it is that it at low rpm (up till about 2000rpm) doenst run smooth.
the last owner did a compression test and said that cylinder nr 6 had lower compression compared to the other cylinders.

the engine does sometimes push out the oilstick and then spray through the "oilstick pipe" oil into the engineroom, the engine does also push small amounts of oil into the IC pipes and though the blowoff valve.

what might the problem be? blown headgasket? jammed/burned valve/valves? damaged piston?

the engine does exept bad idle run perfect without any bad sounds at all.
 

·
Tyne/Wear/Tees Arse Rep/Gtr Shop Rep
Joined
·
11,412 Posts
somthing has went tits up my old engine did this and when i took the sump of found mr piston ring had decided to go on his travels lol
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #4 ·
he he, too bad with that runaway pistonring.

i'm goin to check the compression on them and if there is a problem then pour a few drops of oil in that cylinder with bad compression to see if there is a piston or pistonring problem...
 

·
Registered
Joined
·
441 Posts
will tare off the cylinderhead tomorrow so i hope that it is a easy problem...
Don't bother. No point in taking the head off in situ, you'll be much better pulling the whole engine.

The crankcase is pressurising which means a) you've either too much blowby on the rings or b) there's a blockage somewhere.
 

·
Registered
Joined
·
610 Posts
dude, yer fooked... the worlds gonna end!!!! hehe, im 99% sure yer rings knackered... replace asap.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #10 ·
was the piston rings on the sixth cylinder and had scratched the cylinder so i bought a better used engine instead (was too deep so i had to drill it)
 
1 - 10 of 10 Posts
Top