Skyline Owners Forum banner

1 - 6 of 6 Posts

·
NEW TO ALL THINGS NISSAN
Joined
·
1,103 Posts
Discussion Starter #1


Up until recentley I was going to get a K&N Pod..But a couple of friends both with EVO 7 and 8 told me to go for an Apexi one..

Since then I have been told that the Apexi one : caused turbulence in the afm, causing it to overfuel badly..??

now I dont know if my car will respond in the same way that "STUARTTHEFISH's" did and overfuel..

But I really hope that I dont have to swap my new filter over..



I'd just like to ask any other RB20E drivers what filters y'all have installed in your R33's ???


Please reply asap

Regards



Martin.
 

·
Moderator
Joined
·
12,294 Posts
It may be okay if you locate it further away from the afm, but when bolted directly onto the afm it caused the afm signal to go too high. Don't forget that I've got a gtst though, on your na it might not matter since the airflow won't get anywhere near as high to start with. Mine only had problems while boosting.
 

·
Administrator
Joined
·
25,962 Posts
i had an apexi one in mine and never caused any problems and that ran from standard power right up to 400bhp and mine was an rb25det
 

·
Moderator
Joined
·
12,294 Posts
Mine maxed out the afm signal as soon as I was making boost, hitting 5.12v straight away, which caused the injector duty to skyrocket and my afr's go too rich for my aem wideband to register.

I'd tried repairing the afm, replacing the afm, replacing the wires from the afm to the ecu, tried two different ecu's, triple checked for any leaks, replaced my entire intake twice, etc. I'd been trying to fix it for half a year or so, there are even threads on here that I started while trying to figure out what the hell was going on.

As soon as I got rid of that filter, it cured it, my afm signal never goes above 4.8v, and my afr's now sit happily in the mid 11's at full throttle.

I think it was the cone inside the filter that was the problem, as that ends up right next to the hotwire of the afm. Moving the filter further away on a bit of pipe may have helped, but I saw a brand new k&n for about 30 quid delivered so got that instead to save hassle. Been perfect ever since.
 

·
Seasoned Member
Joined
·
4,504 Posts
Got a Blitz on my gtst as it came with the car and i dont want to pay out any more cash when i dont need to but i would always go for the apexi.

Heres a link to show why http://www.mikekemper.com/elantra/filters/
 
1 - 6 of 6 Posts
Top