Skyline Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi really fustrated atm with my project and just wanting to know if anyone can help out
It's just not shifting right.

I have an r33 coupe,rb20e body. Automatic trans


I have just put in a rb25de+t, rebuilt using the rb25det pistons and rb25det hot/cold side setup.

Car starts up, idles and drives smoothly. No hesitation

I have also removed the rb20e autobox and put in a rb25det autobox.
[Can't afford rb25 manual conversion because it's out of my budget at the moment and brought a rb25det autotrans for $100 because the seller couldn't find a buyer]

I've changed the engine loom, ECU and Trans ECU to the standard r33 rb25det, but the body-loom in the r33 is still the rb20e

any who, i have this weird problem when the car is on D, it seems to take off in gear 2 and even at WOT it'll take it's time on gear 2 instead of down-shifting to 1st, and won't change gears until it reaches about 5rpm's or over.[i believe it's in some kind of limp mode]

You can put it in 1st gear using the selector which works, and then in 2'nd gear,, then to D.[but still won't downshift if WOT normally when in D]

Park, reverse and neutral all work perfectly.

I used my scanner tool and it came up with a error code 54 - A/t communication line

I read somewhere that sometimes when the gears won't change, is because the Trans fluid temp sensor is reading a high voltage and therefore makes the car run only in one gear because it assumes the trans fluid is very HOT.
To overcome this, they used a resistor [2.5Kohm] in between the TFT sensor[trans fluid temp] and pin which goes back to the trans ecu. [Adding a resistor would decrease the current reading to the trans ECU, current = voltage/resistor]

Only problem is i don't know what the actual trans fluid temp-sensor looks like, I've opened up my rb20 gearbox sum underneath but have no clue where or what it would look like.

Does anyone know where the TFT sensor for a rb20/25 is? and what it looks like?


Also, if this doesn't work. I'm assuming i'll have to change the body-loom from rb20e to a rb25de/t incase the the actual pins for the ECU and trans ECU to communicate, are not pinned up correctly due it being a rb20e body....


But i want to try the TFT sensor with resistor first which is easier before i do this body-loom swap.

More info. if needed
-Already changed TPS
-Already changed CAS
-Already changed AFM and 02 sensor
-Already changed IAC valve


ANY HELP PLEASE.
I've literally researched EVERYWHERE and NOTHING
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
Nevermind, just solved it.

It was in limp mode because my A/T Control fuse was blown. 10amps

So i changed that and now it downshifts and changes through the gears
 

·
Registered
Joined
·
1 Posts
Hey mate. Quick question about the conversion from rb20e auto to rb25det.

Would the rb25det mount up against the stock auto transmission in the rb20e auto r33? Or does the transmission absolutely have to be done at the same time?
 

·
Registered
Joined
·
117 Posts
Bad news @Lance33, the original poster has not been seen on here since 2017.
It is against the site rules to dig up/bump old threads though I'm sure folk understand an honest mistake. Always worth checking dates when going through old threads.
Wish I could answer your question for you but no clue myself worse luck.
 
1 - 4 of 4 Posts
Top