Skyline Owners Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Hey,

R33 Gts-t, has been revving by itself as high as 2500+ It's also stalled several times now when driving at low revs (reversing/manoeuvring etc) :(

My abs light was on for awhile aswell and now has gone off (recently had front discs and pads replaced and a wheel bearing passengers side front. Something to do with this maybe? I heard the sensors don't like being disturbed?).

Any idea's? Anything at all would be helpful :)

Possibilities?: carburetor tuning or Tappet?

Thank you
 

·
hippy
Joined
·
7,682 Posts
not likely to be the carb,it doesnt have one! i would do a search for cleaning the idle air valve,this gets gunked up and can cause running issues at low rpm
 

·
R33 GTS25-T
Joined
·
597 Posts
Check for boost leaks, vacuum leaks, clean your air idle control valve, and see about timing.

Those are my suggestions to you. This has nothing to do with your ABS mate.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
not likely to be the carb,it doesnt have one! i would do a search for cleaning the idle air valve,this gets gunked up and can cause running issues at low rpm
Yea! I said that...but my Gf's Grandparents know best! *sigh* :screwy:

Cheers for all your replies!
It was the idle air valve. The cap had come off and caused the loss of power. I've got a plug for it now. Simple fix.
Thanks alot guys!

Oh The abs was a seperate issue. It's not come back on since and I've not had any trouble. If it happens again it might just be a faulty sensor. For now it's ok though.

Thanks again

x
 
1 - 5 of 5 Posts
Top