Skyline Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hey guys

My rb25de starts rough but does not misfire while idling or under load. It is easer to start when hot but still a bit rough.

To me it sounds fuel related as there is no misfiring at all, mt question is would it be more likely to be fuel pump,injectors or fuel filter?

From my experience fuel pumps that are giving out will usually cause hesitation at high RPM but in saying that this car more then likely has its original fuel pump and could probably do with being replaced anyway.

What do you guys think? Is there any more tests I can do to eliminate any of the above?
 

·
Super Moderator
Joined
·
8,969 Posts
Wont be the ECU coolant temp sensor or it would be harder to start when hot, I would look at the air bypass valve (auto choke) if its stuck or failed it will likely cause this problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
I took it off gave it a clean up and put it back on sill no change. I started it yesterday and it died twice during start up third time I gave it a little gas and it started. I changed spark plugs and they all looked good apart from 1 it was black. I also noticed if I let it sit for 30 min its hard to start other wise its ok. This is leading me to think it is a leaking injector or bad fpr.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Replaced the fuel filter today and it is starting allot better but I will wait and see what its like in the morning. Failing pump maybe...
 
1 - 6 of 6 Posts
Top