Skyline Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
449 Posts
Discussion Starter #1
Ok so i just went out in my car and it was warm and i was coasting in neutral and it died!! Steering went heavy and i just dropped the clutch and turned the key and it sparked back up to life no problem. Whenever its in idle its fine but wen i rev the car and let it come back to idle it drops lower than idle and bounces back up, any idea whats wrong?
 

·
Super Moderator
Joined
·
8,968 Posts
I would try doing a throttle reset, as the VQ uses the throttle stepper to control idle.
 

·
Registered
Joined
·
449 Posts
Discussion Starter #3
awesome thanks! just did it and the idle seems much more settled when its been revved. hopefully wont happen again now!
 

·
Registered
Joined
·
449 Posts
Discussion Starter #4
ok i got it wrong! it didnt work!!! i thought it was and havent driven it since testing it until tonight but it stalled again when dropping the clutch, did the ecu reset again and still dropping bellow idle revs and bouncing back up, any other ideas what it could be? a friend at a garage said it could be the throttle body being bit gunged up possibly? would have thought it would stall every time if it was that though!?!?!
 

·
Super Moderator
Joined
·
8,968 Posts
if your still running the std PCV setup then yes the throttle body's do get gunked up, and would benefit from a good clean, but if you disconnect or remove you will have to do the throttle reset again.

The other possibility is it could be down to a bad cam position sensor, also a common problem and a real pain to diagnose correctly.
 
1 - 5 of 5 Posts
Top