Skyline Owners Forum banner

1 - 6 of 6 Posts

·
Cheese Monster
Joined
·
209 Posts
Discussion Starter #1
My Stagea has started smoking on overrun after a stint of full boost.
No smoke throughout normal running but only after holding boost when I come off the throttle.
I have taken the turbo off and there is no real shaft play or endfloat.

This only started happening after I changed the exhaust from the standard to a 3" straight through pipe.

My thoughts;

Less backpressure in the exhaust is causing oil leak from the turbo oil seals after boosting.
It is rare for just the oil seals to go and not the thrust bearing but it is a possibility.

Piston ringlands: could be worn so I will do a compression test on Monday.

Either way, I have a nice new hybrid turbo coming from RSP on Monday.

I will clean the breather pipes and do a compression test etc and hopefully find the issue.

90% think its the turbo though.

If not, I will run a catch tank for a month untill I can afford to do forged pistons and a metal head gasket :)
 

·
Cheese Monster
Joined
·
209 Posts
Discussion Starter #3
what colour is the smoke?

prob just overfueling now since you fitted the bigger exhaust
Defo oil. There is oil in my nice new intercooler now :(

Can only be turbo seals or ring lands - or breathers blocked.


Plus there is SHED LOADS of smoke, like a bond movie smoke screen tool :D
 

·
Cheese Monster
Joined
·
209 Posts
Discussion Starter #4
what colour is the smoke?

prob just overfueling now since you fitted the bigger exhaust
Otherwise I would be right with you here.

With the new turbo - I will be entering custom map time :D


Yam yam yam yam yam .... :boobies:
 

·
Cheese Monster
Joined
·
209 Posts
Discussion Starter #6
Ahh well, engine gone bang now anyhow.

Suspect ringlands, lifters.
 
1 - 6 of 6 Posts
Top