Skyline Owners Forum banner

1 - 8 of 8 Posts

·
formerly known as mruk
Joined
·
3,942 Posts
Discussion Starter #1
PLEASE HELP :( :(

I've returned my car back to standard in the engine so i had to buy another
standard ECU after i fitted a PowerFC beforehand and sold my original ECU.

Car won't start! :( i've checked the fault codes on the ECU and its at 55 so
thats supposed to be fine

I want to find out a part number for a Manual spec1 R33GTST ECU so i
can check if i've not been mis-sold an Auto Spec2 ecu or somet ... ?

Can someone please advise what part number it should have on it as i've ran
out of ideas of what could be wrong with the car....

Thanks !!!
 

·
formerly known as mruk
Joined
·
3,942 Posts
Discussion Starter #4 (Edited)
if its my old ecu it was bought as an r33 rb25det spec 1 and manual to suit my car and it worked fine until i got the pfc,do you have a spark,if not you had to replace coilpacks/wiring and if you have a spark are the plugs getting petrol on them,thanks john

ah, i must've got the wrong end of the stick as didn't think you'd actually had it on the car mate i thought you'd bought it as a spare, wasn't accusing you of doing me over or aout like that , i just thought maybe the person that'd sold it to you may have given you the wrong info

my mate checked it and there is no spark between coilpack and plug, fuel is getting to the plugs and pressure is good, he checked 4 coils
my ignition amp worked fine before i took the car apart and it was kept in the same place while it was of and wasn't dropped so i can't see it being that

I'm screwed! no idea what to check next.... so just clutching at straws really and hoped it was the wrong sort of ECU
i've even gone to the extreme step of contemplating buying a completely standard car in my colour and chucking all the aftermarket bits and selling my car as a non runner :(
 

·
formerly known as mruk
Joined
·
3,942 Posts
Discussion Starter #6
cheerss mate you've confirmed it is the rightpart number putting that to bed!
 

·
formerly known as mruk
Joined
·
3,942 Posts
Discussion Starter #8
yeah, a pro fitted clifford one thats not caused any probs in the past, but i see what you're saying, could've disturbed something possibly while returning it to standard... worth a few thoughts on that mate cheers!
 
1 - 8 of 8 Posts
Top