Skyline Owners Forum banner
1 - 14 of 14 Posts

·
South Wales Area Rep
Joined
·
310 Posts
Discussion Starter · #1 ·
ive been trying to figure my turbo out and not sure what im looking for. when i put my foot to the ground the turbo as far as i know judders (popping) sounds but when i have my foot half way down the turbo work sweet as. wot could the problem be???

is it ment to do that i do have a forced induction kit and intercooler plus a few other mods.

any help or info much appreatated.
 
G

·
Its not turbo mate its your coil packs!
If you ease it up its fine ...but if you give it a quick blast on the throttle it cracks & pops!
Common problem on the Skyline mate its the coil packs breaking down!
Another way to check is take it for a blast..............straight road, foot down and keep looking for the unburnt fuel smoke behind you in the mirror! it will be misfiring but may clear after a certain rev range!
Mine did the same, just changed them and the plugs and its gone!
 

·
South Wales Area Rep
Joined
·
310 Posts
Discussion Starter · #3 ·
how much is that going to set me back bro???
 

·
bla
Joined
·
17,374 Posts
Could be a number of things.. Most common are Plugs, Coilpacks, AFM.

Most the time AFM causes issues at low revs, Coilpacks is higher in the rev range 4500rpm to say 5000rpm..

If its higher in the rev range, It should be ok when going slower to redline, but when full throttle a coilpack will break down due to the extra stress/heat...

Buy some new plugs first... What plugs are you using? How old are they??

By the sound of your spec you will need Iridium's, .8
 

·
Registered
Joined
·
552 Posts
Fixed the same issue with mine today, new NGK 7's and also taped up the coilpacks and no more missfire :) pulls lovely again all the way to 7K
 

·
Registered
Joined
·
52 Posts
Same for me!!!!!!!

Only had the car 2 days when the missfire started

set of RSP coil packs and some NGK iridium plugs (heat range 7, gapped to 0.8mm)

Perfect apart from a bit of overboost but that's another prob
 

·
South Wales Area Rep
Joined
·
310 Posts
Discussion Starter · #9 ·
cheers for the info lads i will get on it and get back to you to let u know.
ive only just got the car 2 wks ago so dont know to much about her YET!!
 

·
South Wales Area Rep
Joined
·
310 Posts
Discussion Starter · #11 ·
sounds a common problem with the skyline then ppl gggrrrr its always money money money aint it.... oh well she needs to be done i suppose
 

·
South Wales Area Rep
Joined
·
310 Posts
Discussion Starter · #13 ·
happy days lol its worth every penny.
 
1 - 14 of 14 Posts
Top