Skyline Owners Forum banner

21 - 28 of 28 Posts

·
Craft Beer Drunkard
Joined
·
611 Posts
Which coil packs would be better - "Splitfire" or new stock ones(nissan oem)?
GM LQ9/LS7

what is a tps? where is it located?
Throttle position sensor, located on the side of the throttle body. So the ECU knows the percentage the throttle is open. There is also a TPSW on these cars, Throttle position switch which reports to the ECU full open or full closed.
 

·
Madman Sometimes
Joined
·
225 Posts
have you changed the coil packs yet?? the pic you showed has the rubber sleeves missing, like i said i had the misfire on positive boost changed my plugs and coil packs no more missfire. they are expensive mate but go for the red jacket ones you can get them off ebay for around £200 if you fish about. they are well worth the extra tho i got mine from japan worth the wait tho
I bought these red jacket coils i payed £300 and need to replace them as two of them have packed in, they are about two years old but car is not used all the time if i were you i would go for splitfires i personally would not buy red jackets again.
 

·
Registered
Joined
·
4,045 Posts
Stock over splitfires easy.

Dont get me wrong are great but we no the life expectance of stock is about oh 15 years!! In most cases it will out last the car.
 

·
Registered
Joined
·
4 Posts
I would be a great idea to change your coils but i had thé same problem it was goinfre crazy at 4-5k rpm and doing backfires it was ur CAS ! Its a tricky piece that works with your timing so stop driving it and go buy a CAS
 

·
Registered
Joined
·
1,527 Posts
Also work remembering that the fluctuating tickover can be caused by having a BOV fitted. My 1st GTST had terrible running problems. OK when it was cold but once warmed up the tickover went from 800-2500rpm. It used to cut out at traffic lights as well. Bloody awful. After refitting the oem recirc valve it was 1000% better. No hunting and no stalling.
 

·
Registered
Joined
·
1 Posts
i have a simular problem withe the tps on my r33. but mine wont idle. only four a few sec. then dies. kan you conferm if your tps is broken?
How did you fix this my r33 20e auto is doing g this I cant find what's the problem any help would be great
 
21 - 28 of 28 Posts
Top