Skyline Owners Forum banner

1 - 8 of 8 Posts

·
Banned
Joined
·
1,183 Posts
Discussion Starter #1 (Edited)
Right as the title says..

You will have to bear with me... The car has started to run lean, starting to produce knock of 150 ish and coughts and spultters evry now and then :confused:

the spec is

spec 2 engine
splitfires
ngk 7
550cc injectors
walbro 255 fuel pump
hybird turbo
1.6mm head gasket
pon cams
60mm rad
FMIC
PowerFC
AVCR
triple plate clutch

runing 401 bhp. Now my tuner says that the fuel aint man enough for the job. SO

1. What BHP does the walbro max out at?
2. Do i need to earth the pump out to always get the MAX out of it
3. Maybe **** in the fuel filter?
4. Map is wrong? (cant see this being problem)
5. Do i need a BOSH 044 pump?
6. Lamba Sensor?

also this is a intermitted problem and some times i only see 12 knock and sometimes 150+ knock

Any help ASAP would be great guys

cheers
 

·
Banned
Joined
·
1,183 Posts
Discussion Starter #5
no i aint, tesco 99 stuff all the time. Im hoping its just crap in the filter.

Just went to check some thing on the car and now its ticking over at 1500 revs :confused:

air leak somewhere????????????
 

·
Registered
Joined
·
83 Posts
As bigchief said it shouldn't be the pump (unless it's failing). I'm running 650cc injectors and 506 bhp on a walbro but I had to do the earth mod to get full capacity from it. Have you done anything that could of altered the ignition timing? ie. cam belt change or re-tension etc. Because even a couple of degrees more advance than it was mapped with would cause the knock problems you have.
 

·
Banned
Joined
·
1,183 Posts
Discussion Starter #7
nope nothing mate aint touch the thing. How do i do the earthing mod? ill do that and change the fuel filter and see how that goes. Has anyone got a idea on the revving issue now?
 
1 - 8 of 8 Posts
Top