Skyline Owners Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3,540 Posts
Discussion Starter · #1 ·
Ok first of all its on my R33 GTST

Over the last few days ive noticed the car idleing very high compared to normal. On start up it idles at 2000 RPM and even when its upto full temperature it idles around 1400 RPM.

Ive adjusted the idle control valve do help it a little but after a while the revs now drop right down to 500 RPM on idle because ive adjusted it, it even stalled earlier cos of it being too low now. Mind you it does take almost 30 mins of driving before it does down to 500 RPM which would be normal if i hadnt adjusted it.

My thoughts atm are either a dodgy Coolant Temperature Sensor or the auto choke is sticking or something. Do they have a secondary air injection system for warm up that could be at fault? And is there anyway of dissableing the choke so i can elliminate that?

Thanks in advance for your help lads

Mike
 

·
Registered
Joined
·
4,050 Posts
Try unplugging the ICV when the car is running see if that does anything, then try cleaning it... Does the idle hunt? is there any smoke from exhaust at all while driving? does the car flat spot/hold back under load, could also be the cold start valve (think it called that) also try your plugs, are they clean/gapped correctly.

Then if that fails try fuel filter and then afms and try your vacuum pipes
 

·
Registered
Joined
·
3,540 Posts
Discussion Starter · #3 ·
Will unplug the ICV later an see what that does. I cleaned it out only 3000 miles ago so shouldnt need to do that again yet.

No hunting or any flat spots either, runs spot on just not on idle lol.

Where do i find the cold start valve?
 

·
Registered
Joined
·
3,301 Posts
I would say its probably water or moisture messing with the AFM. I'm going to be building an alloy cover for it to stop water getting in.
 

·
Registered
Joined
·
3,540 Posts
Discussion Starter · #7 ·
Will see how it is later when i actually drive it properly, only started it quickly this morning.

It had only started messing about when the cold weather really kicked in so fingers crossed it was just that
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top