Skyline Owners Forum banner

1 - 20 of 20 Posts

·
Banned
Joined
·
5,275 Posts
Discussion Starter #1
Now I'm gonna find this hard to explain, but someone may be able to help.

As posted in my other thread, new FMIC fitted-great-now pulling 0.9 bar, but............
It may be just me but not being able to get much open road over the last couple of days to do proper test.

It seems to me that when i hit 2nd stage boost(4500rpm) it definately has more initial pull but it just seems to take longer to hit 7000 as if there's not as much urgency to get there, I used to be bouncing off the rev limiter most of the time(especially in 2nd)

I find it hard to put into words what it is like but the best way of describing it is that it is like someone is strangling it i.e it can't get enough air or fuel?????

ideas anyone?
I wondered if it was worth investing in one of those Air/fuel guage thingies

Pete
 
S

·
Guest
Joined
·
0 Posts
it could be that what you are describing is more lag.

I have read somewhere that switching to an FMIC without uprating the turbo introduces more lag as it takes longer to pressurise the system (more pipework to fill)

Just a thought (or I could be talking rubbish again! :))

Simon
 

·
Member No 48
Joined
·
1,192 Posts
Have you reset your ECU yet? Maybe it needs to learn the new airflow through your engine?
 

·
Banned
Joined
·
5,275 Posts
Discussion Starter #4
Floyd........done that the other day, when I did it initially reverted back to 0.7bar but after a bit of a thrashing it went back up to 0.9


simon......not saying you are wrong but I would have thought the lag would have been lower down in the rev range



anyone?

I'm gonna try to take things easy until I sort it just incase I'm running lean
 

·
Banned
Joined
·
852 Posts
Pete,

I've got a GTR FMIC and standard turbo usually running at 0.8 bar and when I hit boost it pulls like f*ck right up to the limiter. The car was like this when I got it so I don't know what the lag would have been like with the original intercooler.

On my AVCR I haven't seen my injector duty go above 50 odd % even when I'm giving it a damn good thrashing. I had the fuelling checked by Rod Bell earlier this year and he said it was good. I have got a Blitz access ECU though, is yours the standard.

You will have introduced more lag into the system due to the increased volume of the pipework and intercooler, don't know what boost you were running with the standard parts but if it was say 0.8 and you are running the same boost now then you are still pushing through the same volume of air (remember the turbo is just an air pump) but as I say you have more pipework to fill and your injectors will have to work a bit harder cos the bigger intercooler should be supplying colder air giving you a denser charge. I think thats right anyway.

For piece of mind get your fuelling checked, it doesn't take long but it sounds like your describing lag to me.

If memory serves me correctly (which it usually doesn't) the definanitionof lag is something along the lines of .....

lag is the delay between a change in throttle and the production of noticeable boost when the engine rpm is in a range where boost is achievable.
 

·
Banned
Joined
·
5,275 Posts
Discussion Starter #7
I've just been and bought an Air/Fuel ratio meter so I'll stick it on either later or tomorrow and see what the score is there
 

·
Registered
Joined
·
469 Posts
Why has fitting a FMIC increased your boost pressure ? This sounds to me like you might indeed have some sort of restriction, can't otherwise see how changing the intercooler would increase boost.
 
N

·
Guest
Joined
·
0 Posts
good point , grebo , i cant either , i can understand the bigger volume of air , hence the turbo has to work harder . 2 fill this volume .
But increased boost no .
 

·
Registered
Joined
·
3,716 Posts
Pete,
What other mods do you have?
 

·
Banned
Joined
·
5,275 Posts
Discussion Starter #12
Only mods are decat, downpipe, exhaust, pod filter and SSQ bov

My slant on the boost going up is that there is less restriction in the new Fmic(I have heard that with a standard cooler the turbo can be pushing out about 5psi more than is seen at the intake)

Anyway today tried to fit the Air/fuel meter, what a f*ck up!!
When it was connected it was dragging the 02 sensor voltage down from 0.278v to 0.046v
Got to go back to the supplier to source another type which won't put a load on the sensor OR fit another 02 sensor
 

·
Registered
Joined
·
3,716 Posts
The standard management units are rumoured to be able to cope up to 0.9 bar. My car had problems with lack of injector overhead and maxing out the air flow meter at 0.8bar leading to a seriously large hole being formed in my wallet

Paul
 
N

·
Guest
Joined
·
0 Posts
AHa , how does that work , standard cooler ?
pressure is pressure , in any form .

please explain ?
 

·
Registered
Joined
·
3,716 Posts
the pressure drop end to end on the FMIC is less than that of the standard IC. So if the pressure is measuredat the manifold but controlled at the turbo then there is a net gain
 

·
Banned
Joined
·
5,275 Posts
Discussion Starter #16
I've ordered a new Lambda(o2) sensor today as I think mine is knackered, also I have spoke to Tony @Abbey who was very helpful and on his advice I have blocked up the little pipe with the brass restrictor in it so that the car is running on actuator pressure which should take me back to 0.65bar until I can establish how my car is fueling.

p.s. if anyone else needs a Lambda sensor you cannot use a "universal one" on the skyline. The nissan part number for a series 1 gts-t is 22690-83T10 £86+vat:(
 

·
Banned
Joined
·
5,275 Posts
Discussion Starter #17
Do not do what I said with that pipe,

Holy shish, I did it last night and didn't drive the car till this morning, I put me foot down and the boost guage nearly did a 360, me and Tony must have got our wires(pipes) crossed as we were both trying to visualise the layout
Anyway I put it back as it was so I will look into it over the weekend
 

·
Dandy Highwayman
Joined
·
1,314 Posts
must say it sounded odd but wasnt about to question tonys word :D if you block the pipe i think you blocked the wastegate actuator is not seeing any presure and so never opening
 

·
Registered
Joined
·
44 Posts
Well I have to admit to you guy's that sadly I do not have even the slightest clue about any part of this thread, and that makes me mad. How do you know all this stuff??
 
E

·
Guest
Joined
·
0 Posts
Through logging onto this place at every opportunity. Theres a lot to be learnt by reading mate. Some of us even learned how to get past the swear filters last week as well. Shame i ****ing didn`t.
 
1 - 20 of 20 Posts
Top