Skyline Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Imported my skyline, but haven't registered it yet due to a couple issues ive been tracking down.

It had a stalling issue when rolling to a stop. Also cylinder 6 had issues on idle and unplugging the coil pack would have no effect on the idle. Swapped coilpack from cylinder 1 to 6 and issue remained on cylinder 6. Also just changed plugs and added wiring specialties coilpack harness.

Started chasing vacuum leaks with carb cleaner on the hoses and found the idle to change when I sprayed cylinder 6 injector. Guessing O-ring went bad.

Wondering if a leaking injector o ring would also effect the idle issue I was having on cylinder 6.

Will probably work on taking out the injectors and getting them cleaned with new fittings. Any tips on removal/install of injectors on rb20det?
 

·
"A Skyline with 4 doors?"
Joined
·
380 Posts
Does it have a blow off valve that vents to atmosphere? (doesn't recirculate into the intake before the turbo but after the MAF) If so that's likely the cause of the stalling when going to a stop.
 

·
"A Skyline with 4 doors?"
Joined
·
380 Posts
The key is if the factory recirc valve plumbs back into the intake. That's because that air that has been accounted for by the MAF. If it vents to atmosphere, your stock ECU would be fueling to match having that air accounted for and causes a quick rich/flooded condition that will stall out the engine when coming off boost. If you've got a stock recirc valve and it's plumbed back into the intake as stock, then that shouldn't be a cause. Just trying to eliminate the common issues first.
 

·
Registered
Joined
·
1 Posts
Had the same issue with mine. Swapped back to a recir bov and didn't fix the issue. replaced the coilpacks and spark plugs, still didn't fix it. Ended up picking up a bottle of MAF cleaner and Carb cleaner. took off the MAF and the AAC, cleaned both. Reset idle and fixed it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Ended up replacing the injector o rings and it no longer stalls. Though the RPMs do dip down quite a bit when I pull up to a stop and clutch in. I raised the idle to prevent stalling, but I believe this issue is due to a lightened flywheel. Has a ORC single metal clutch set.
 
1 - 6 of 6 Posts
Top